I have 8 dynamixels that are connected together. Everything worked fine until I changed all their ids to 200,201,202, ... To change their ids, I used this python library. Now, none of my motors are detected. I tried testing one motor at a time and I have the same results for all motors.

I tried running factory_reset.py from DynamixelSDK and the script returned:

Succeeded to open the port

Succeeded to change the baudrate Now the controller baudrate is : 1000000

[ID:001] Try factoryreset :


[TxRxResult] There is no status packet!

Any idea why I have this error, and how I can fix this? Thank you.

  • $\begingroup$ you did not say how you changed the IDs $\endgroup$ – jsotola Dec 29 '19 at 22:31

Try a for loop with all possible ids until it is detected.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.