-1
$\begingroup$

I wanted to use the NEMA 17 stepper to drive a blade/flapper that I have custom made for some physical application.As soon as I tighten the screw,the motor stops rotation in the usual way. Don't have any idea the reason for this. Note: 1.The blade/flapper is not too heavy and the torque rating of the Motor is sufficient. 2. Doesn't spin even if I help with hand 3.It does a very slight movement almost at the same place. 4. Problem occurs as soon as I turn the screw to fix the blade on the shaft. 5. I've tried with using glue into the joint,the problem seems to be lessened but still present,also using the glue method wouldn't be suitable for my function as I need more rigid join.

$\endgroup$
  • $\begingroup$ No ofcourse not,it stops when I have already attached, have tried my best to explain the problem,my bad. $\endgroup$ – sagnik das Mar 21 at 18:31
  • $\begingroup$ I don't know much about motor or the mechanical terms associated with it or its working,still,I have edited with some more information.Ty $\endgroup$ – sagnik das Mar 21 at 18:43
  • $\begingroup$ Welcome to Robotics, sagnik das. As @jsotola mentions, it's not clear what the problem is. How are you powering and driving the stepper motor? You need to do more than just apply power to it, it needs to be (electronically) stepped to rotate, and it sounds like you're not doing this. Can you please edit your question to post a schematic of how you have the motor wired and a picture or video of what screw you're tightening to secure your attachment? $\endgroup$ – Chuck Mar 21 at 20:15
  • $\begingroup$ if you can, please post a picture of the motor by itself .... also a picture of the motor with the blade attached $\endgroup$ – jsotola Mar 21 at 22:24
  • $\begingroup$ Okay I'll edit again with more details and can anyone tell how to post pic here? $\endgroup$ – sagnik das Mar 22 at 1:05
2
$\begingroup$

I will take a wild guess - your accellerating to fast for the mass of the blade / power of the stepper motor.

You can check this by trying to step much slower - perhaps 1 step per second for testing

$\endgroup$
  • $\begingroup$ Yes,I increased the delay, working now! $\endgroup$ – sagnik das Mar 26 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.