-1
$\begingroup$

My Turtlebot2 Gazebo simulation is not able to produce Scan data.

Steps to produce the problem:

roslaunch turtlebot_gazebo turtlebot_world.launch
rostopic echo /scan

As soon as I ran the “rostopic echo /scan” the turtlebot_gazebo node crashed. This is the error output:

gzserver: /build/ogre-1.9-mqY1wq/ogre-1.9-1.9.0+dfsg1/OgreMain/src/OgreRenderSystem.cpp:546: virtual void Ogre::RenderSystem::setDepthBufferFor(Ogre::RenderTarget*): Assertion `bAttached && "A new DepthBuffer for a RenderTarget was created, but after creation" "it says it's incompatible with that RT"' failed.
Aborted (core dumped)

I’m working towards learning about the scan messages and Lidar data so I need the simulation to work. I would appreciate any advice to help me resolve this issue. System info:

Ubuntu 16.04 
ROS Kinetic 
Gazebo 7 
Installed Turtlebot 2 based on Indigo install, but replaced with kinetic

.

$\endgroup$
  • $\begingroup$ perhaps the reason why you are not getting any responses is because you asked a question that a user would ask ...... a programmer would ask how to prevent the turtlebot_gazebo node from crashing $\endgroup$ – jsotola Jan 30 at 1:54
  • $\begingroup$ At this point I am a user. This is a configuration issue. $\endgroup$ – Scott Jan 30 at 6:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.