I'm making a drawing robot and have hooked up my steppers to each axis. I'm using the grbl shield with arduino and nema 17 steppers.

Initially the firmware was set at 250 steps/mm but with my setup this would move my axis by 50mm. Therefore I only need 5 step/mm. However now that I have put it to 5mm my steppers run very slowly and vibrate quite a bit.

This is the case even when I command an axis to move a set distance. For example, with 250steps/mm I can tell the axis to move 2mm in universal gcode sender (actually 100mm physically) and it will move swiftly and quietly. However with the setting at 5 steps/mm I can command it to move 100mm and it will be very slow, loud and vibrate like hell. This behaviour is seen even without changing any feedrate, max acceleration and speed settings.

Any ideas how I could fix the issue? Is 5 step/mm reasonable? I'm just using standard T-20 belts and pulleys so other people must also have this setting.

Thanks in advance!

  • $\begingroup$ According to your question, it is a hardware problem of a drawing robot. It's the first time, that somebody has problems with hardware but not with software. Usually, hardware is the easiest part in a Robotics project, because it is well documented, contains many experience of previous projects and is sold as customer product in retail store. Did I have your problem understood right, that a stepper motor is too loud and you simply ask for a better one which is an COTS product? Or did I miss something, and the problem is much more complicated and has to do with software hidden in the project? $\endgroup$ Nov 20, 2018 at 12:57
  • $\begingroup$ Welcome to Robotics, Stephen. You said, Initially the firmware was set at 250 steps/mm but with my setup this would move my axis by 50mm. I don't understand why a steps-to-distance ratio is limiting your motion. At 250 steps per millimeter, you should be able to go any distance, it just requires lots of steps. Is there some other limiting factor here, like overflow or underflow of encoder counts? Can you link any datasheets for the components you're using or a video of the behavior you're experiencing? I can't tell why you're wanting to move from 250 steps/mm to 5. $\endgroup$
    – Chuck
    Nov 20, 2018 at 16:53
  • $\begingroup$ Thank you for the reply Manuel, my issue isn't with the hardware I don't think, it is very loud for a stepper and vibrate a lot but my 3d printer doesn't make that kind of noise and my CNC is very similar design so I am guessing it is my settings that need to be changed. It may be that I need to add some gearing. My steppers are linked and I think are more than adequate for the application. They are Quimat Nema 17 Stepper Motor 1.7 A 0.59 Nm. tinyurl.com/ycx2z3h7 $\endgroup$
    – Stephen
    Nov 21, 2018 at 22:44
  • $\begingroup$ Thank you for the reply Chuck. I don't want to move from 250 to 5, of course that reduces my resolution and accuracy. However with my current set up with 250steps/mm it rotates my pulley/shaft 1.25 revs and that corresponds to 50mm movement of the gantry. To correct this ratio I then have to set it at 5 steps/mm so that in my gcode when I command it to move 1mm it does so instead of moving 50mm. This is of course not good and I would prefer more steps/mm. (1/2) $\endgroup$
    – Stephen
    Nov 21, 2018 at 22:51
  • $\begingroup$ The second issue is that when I have it set to 250 and command the gantry to move a distance, say 100mm, I of course ask it to move 2mm in gcode because the calibration is off. With 250 it runs smoothly as expected. However when properly calibrated with the 5steps/mm set, when I command the gantry to move 100mm it is much louder and slower than when it is set at 250steps/mm. But in both cases the motors and gantry are commanded to do the same thing. I will get videos for clarity (2/2). $\endgroup$
    – Stephen
    Nov 21, 2018 at 22:55


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.