5
$\begingroup$

Whenever I try using openni_launch, it works normally, however, when I try viewing an image using the kinect's rgb or depth camera, or even recording a simple bagfile with data from the kinect, I am unable to see any picture and rosbag does not record any data, and after a few seconds of running image_view or rosbag record, I got this error:

terminate called after throwing an instance of 'openni_wrapper::OpenNIException'
  what():  virtual void openni_wrapper::OpenNIDevice::startImageStream() @ /tmp/buildd/ros-groovy-openni-camera-1.8.8-0precise-20130418-2203/src/openni_device.cpp @ 224 : starting image stream failed. Reason: Xiron OS got an event timeout!
[camera_nodelet_manager-2] process has died [pid 3788, exit code -6, cmd /opt/ros/groovy/lib/nodelet/nodelet manager __name:=camera_nodelet_manager __log:=/home/rosbotics/.ros/log/16b63744-e043-11e2-ac16-080027486aa8/camera_nodelet_manager-2.log].
log file: /home/rosbotics/.ros/log/16b63744-e043-11e2-ac16-080027486aa8/camera_nodelet_manager-2*.log

After searching around and trying various fixes, I figured it might be a problem with openni and started using freenect, however I encountered the same problems, I could not record any data using bagfiles or see any images from the kinect (using rviz or image_view)

Then someone asked me to use something completely unrelated, freenect-glview, however that too gave me a black screen.

lsusb shows that all 3 parts of the kinect are connected and I've been able to control the kinect's motor through ubuntu so I know that there is at least a connection established between both.

Additional Info:

  • I run ROS on Ubuntu using VirtualBox V.4.2.14 and Windows 7 with USB 2 ports

  • I am using ubuntu 12.04 and ROS-Groovy (all up to date)

  • I've had the exact same errors on my Mac OSX Lion

  • When I try using Rviz with the kinect, VirtualBox crashes all together

I would appreciate anyone's help on the matter.

$\endgroup$
0
$\begingroup$

It turns out VirtualBox was causing everything to not work properly for some reason. Now I'm using VMware and everything's running fine. What confused me was that I was getting errors that I found online and that even after trying every fix I could find some would still be there. Next step is getting XYZ coordinates of a moving robot, I'll start looking for tutorials right away (I'm still new to ros).

$\endgroup$
  • $\begingroup$ Can you elaborate on what VMware is doing correctly that VirtualBox was not? $\endgroup$ – Ian Jul 23 '13 at 2:33
  • $\begingroup$ I don't know what exactly was the problem but the result was that I was unable to view any images from the kinect or acquire any depth/rgb data from it even though I was able to control the motor just fine. When I switched to VMware it worked perfectly fine with freenect. Openni still has a few hiccups but I can make it work on VMware too. $\endgroup$ – Y R Jul 23 '13 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.