1
$\begingroup$

I have 2x 350W wheel-hub motors taken from a self-balancing scooter, or hoverboard. My intention is to use the two of them to drive a homemade R2-D2. However, some difficulties have been encountered that make it seem as though I am missing something trivial.

The ESC in question is a Hobbyking Quicrun 16BL30, driven by an HJ Servo Tester. Power supplies used include a 7.2V 1200mAh Ni-Cd battery, a 9.6V 900mAh Ni-Cd battery, and the 12V 18A rail of an ATX power supply. In testing configuration, the wheel-hub motor is clamped to the desk (no physical load). The ESC was programmed to the following values:

  1. Running Mode: Fwd/Rev.
  2. Drag Brake Force: 0%.
  3. Low Voltage Cutoff: Disable.
  4. Start Mode (Punch): Level 5.
  5. Max. Brake Force: Disable.
  6. Max. Reverse Force: 100%.
  7. Initial Brake Force: 0%.
  8. Throttle Range: 9% (Normal).
  9. Timing: 11.25 deg.

Upon calibration and power-up, everything goes fine. However, driving forward/backward, the motor only runs for 3 seconds before stopping. The ESC light remains indicative of a load in that direction. When returned to neutral, then to run, it will go again. If done 3x or 4x, the ESC light will remain red when returned to neutral (indicative of an incorrect signal, or faulty connection to the motor). The ESC only needs reset to allow for 3s drives again. If alternated between forward and neutral at 1s intervals, it will continue running.

The instructions, manufacturer forums and google have failed to reveal another user encountering this problem. In a prior session, before accidentally resetting the ESC to all-default values, the wheel functioned perfectly for a few minutes. I feel as though I must be missing something trivial.

What am I missing?

$\endgroup$
  • $\begingroup$ Did you find any suitable mode to drive these brushless motors? Thanks $\endgroup$ – Albstrof Jan 31 at 12:26
  • $\begingroup$ I was mistaken to believe that these motors would operate at a third of their normal (37-volt) voltage by tripling the current. Higher-voltage ESCs permitted the smooth driving of the motors. That is what I was missing. $\endgroup$ – user17183 Mar 3 at 5:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy