0
$\begingroup$

So I have an E-puck robot, and I'm using Tiny Bootloader from this website: http://www.etc.ugal.ro/cchiculita/software/picbootloader.htm

I've paired the robot up on my laptop's bluetooth. It appears in the devices window on Control Panel (I'm using a Windows 10 laptop BTW with built in blue tooth.), I pair the robot and windows gives me a COM port. So far so good.

I start Tiny Bootloader v1.98 and set it to load a .hex file so I can start making the robot do things. I find and select the right COM port and hit Write Flash.

It gives me the following message:

Could not connect to com3 at 115200 ERROR!

I don't really know what to do next. None of the tutorials I've found regarding the use of the robot say anything about how to handle this. Other people who've experienced problems with Tiny Bootloader have at least managed to connect to their device before they get an error.

$\endgroup$
1
$\begingroup$

It seems to me that the baud rate might not be the one expected by your robot. Try to force the baudrate of the communication to other standard ones, or look in the doc of the robot if anything is said on the expected baud rate

$\endgroup$
  • $\begingroup$ I'm afraid I don't know anything about baudrates or how to force them. There was a little drop down menu called comm on the tiny bootloader that had different numbers besides 115200. I tried them all, they all gave the same error. $\endgroup$ – Matthew Nichols Nov 14 '17 at 13:48
  • $\begingroup$ Ok then try to use a wire connection to the serial to eliminate bluetooth from possible issue. You can find infos on preoject website e-puck.org/index.php and reseller wiki gctronic.com/doc/index.php/E-Puck $\endgroup$ – N. Staub Nov 14 '17 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.