0
$\begingroup$

I am trying to run "px4 SITL simulation" using gazebo7 on my machine with "UBUNTU-14.04 LTS" using these commands:

mkdir -p ~/src
cd ~/src
git clone https://github.com/PX4/Firmware.git
cd Firmware
git submodule update --init --recursive

But as I enter the next command i.e :

make posix_sitl_default gazebo

It gives an error -->

CMake Error: The source directory "/home/arpit/src/Firmware/build/posix_sitl_default/-Wno-deprecated" does not exist.
Specify --help for usage, or press the help button on the CMake GUI.
/bin/sh: 1: cd: can't cd to /home/arpit/src/Firmware/build/posix_sitl_default 
make: *** [posix_sitl_default] Error 2

Any Solutions?

$\endgroup$
  • 1
    $\begingroup$ There might be a problem in the Makefile. Particularly, the fact that the build directory and one of the C flags are concatenated together. I would suggest checking out a certain tag (1.6.5 seems to be the latest?) and build that. You might have taken the code at some buggy in-development state. $\endgroup$ – Shahbaz Oct 26 '17 at 15:06
  • $\begingroup$ I think you executing make command in the wrong directory, please go to build and execute make command, please let me know whether it works? $\endgroup$ – Monika Dec 18 '19 at 19:41
0
$\begingroup$

There's something wrong with the Makefile where this is breaking depending on your exact setup. As a quick fix I would hack out the -Wno-deprecated from the Makefile, and I'll look at fixing this.

| improve this answer | |
$\endgroup$
0
$\begingroup$

I think there is a missing space in the makefile. the flag should be on a separate line from directories. That is as far as I can say since I don't have the file.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.