0
$\begingroup$

I bought a new Roboduino atmega 328 board. Basically Roboduino is a modded version of Arduino UNO made by robokits.co.in. The problem is

On Windows Plaform: When I tried to upload a simple Blink program that's listed in the examples of Arduino IDE 1.0.4, I got error that avrdude: stk500_getsync(): not in sync: resp=0x00

I chose the correct COM port after verifying it with the Device manager. I installed the Prolific Drivers for the board. I selected the board as Arduino UNO in Arduino IDE.

The complete verbose for the upload is as follow:

D:\Softwares\Installed Files\arduino-1.0.4\hardware/tools/avr/bin/avrdude -CD:\Softwares\Installed Files\arduino-1.0.4\hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -carduino -P\\.\COM10 -b115200 -D -Uflash:w:C:\Users\ANKITS~1\AppData\Local\Temp\build5865304215250534760.tmp\Blink.cpp.hex:i     
avrdude: Version 5.11, compiled on Sep  2 2011 at 19:38:36
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch
         System wide configuration file is "D:\Softwares\Installed Files\arduino-1.0.4\hardware/tools/avr/etc/avrdude.conf"
Using Port                    : \\.\COM10
Using Programmer              : arduino
Overriding Baud Rate          : 115200

avrdude: Send: 0 [30]   [20]   
avrdude: Send: 0 [30]   [20]    
avrdude: Send: 0 [30]   [20]    
avrdude: Recv:    
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.

When I plug in the board the power LED is on. The 13 pin LED blinks once. When the IDE shows uploading the 13 pin LED blinks 3-4 times and then the error appears on the screen. In between also sometimes it blinks randomly for 5-6 times. I also tried other example programs but the same follows. I'm using 32 bit Windows 7 Ultimate and the baud rate is set to 9600.

On Ubuntu 13.04: I downloaded the IDE from Software Center. I was added to the dialouts group on the first run. After connecting the board to my pc I ran two commands lsusb which returned following output:

Bus 004 Device 003: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

and then dmesg. After this when I tried to upload the same program of blink, it gave me following error:avrdude: stk500_recv(): programmer is not responding. I'm using 64 bit ubuntu 13.04 and selected Arduino UNO as the board.

Thank you for reading this long. Please provide me suggestions for the problem.

$\endgroup$
2
  • 1
    $\begingroup$ You wrote 9600 baud with windows, but the output shows 115200 baud? $\endgroup$
    – ott--
    May 23 '13 at 19:55
  • $\begingroup$ Thae's actually the overiding baud rate. Nyways the problem got solved look at my answer. $\endgroup$
    – meteors
    May 24 '13 at 9:11
2
$\begingroup$

I finally got the problem solved. The problem was that I had selected Arduino UNO. After checking out the datasheets for my board I found that it had the same specs as Arduino Duemilanove AtMega328. After selecting it I got the things right. So the general solution is check out the data sheets if you are using any such modded boards and then select the appropriate board which matches the specs. Now my board is working successfully on both windows and linux.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.