Do other Roombas have an Open Interface like the Create2? Can I send commands to my 780 like the Create 2?

I am trying to control my Roomba 780 I made a 8pin FDTI connector to USB and my roomba beep once when plugged in. The logic level is 3.3V

Here is my python code:

#!/usr/bin/env python

import serial
import time

#start usb connection able with Roomba
usbCom = serial.Serial(port='/dev/ttyAMA0', baudrate=115200)

#initialze roomba and put it in safe mode

#spot mode clean

I've sent my serial data from my Raspberry PI to my Roomba but it is not responding, it seems to stop at the first line when I send a byte.

  • $\begingroup$ Asking if a robotic vacuum supports a certain API seems pretty on-topic to me... $\endgroup$ – Ben Jul 14 '17 at 18:25
  • $\begingroup$ @Ben - Arguably more of a pre-sales/tech support question for iRobot. $\endgroup$ – Chuck Jul 14 '17 at 18:28

Problem solved.

I was connected to the wrong serial port. Connecting to '/dev/ttyUSB0' fixed it.

| improve this answer | |
  • $\begingroup$ Welcome to Robotics Mike. Thanks for your answer but we are looking for comprehensive answers that provide some explanation and context. Very short answers cannot do this, so answers that don't include explanations may be removed. $\endgroup$ – Mark Booth Jul 12 '17 at 14:32
  • $\begingroup$ Mike, if this did solve your question, then please accept it with the check mark to the left of your answer. This marks the question as solved and helps future visitors find answers faster. $\endgroup$ – Chuck Jul 14 '17 at 18:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.