0
$\begingroup$

I'm following these instructions on how to install Indigo: http://wiki.ros.org/indigo/Installation/Ubuntu

When I enter the command: sudo apt-get install ros-indigo-desktop-full I get the following output:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.  
The following information may help to resolve the situation:

The following packages have unmet dependencies:

ros-indigo-desktop-full :  
Depends: ros-indigo-desktop but it is not going to be installed  
Depends: ros-indigo-perception but it is not going to be installed  
Depends: ros-indigo-simulators but it is not going to be installed  
Depends: ros-indigo-urdf-tutorial but it is not going to be installed  

 unity-control-center :  
Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed  
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed  

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

According to the instructions I am following, unmet dependencies should be solved with either the command

sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libxatracker-dev-lts-utopic libopenvg1-mesa-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libgbm-dev-lts-utopic libegl1-mesa-dev-lts-utopic

or

sudo apt-get install libgl1-mesa-dev-lts-utopic

However when I try to use these commands I get unable to locate package errors such as

E: Unable to locate package libgl1-mesa-dev-lts-utopic

I'd appreciate any advice on how to solve these dependency issues. I've already asked on ROS Answers but received no answer, and the technician in charge of the computer lab I'm working in hasn't yet found a solution, so... help me stack exchange, you're my only hope.

P.S. I'm assuming that this question goes in the robotics section because it's related to ROS, but if this belongs in the Ubuntu or main stack overflow section please let me know.

Edit: things I have tried so far
1. sudo apt-get update and sudo apt-get upgrade, changed nothing.
2. When I type in apt-cache libgl1-mesa-dev-lts-utopic I get E: Invalid operation libgl1-mesa-dev-lts-utopic
3. When I type in apt-cache search libgl1-mesa-dev-lts-utopic I get no output.
4. When I type in ls /etc/apt/sources.list.d I get ros-latest.list ros-latest.list.save

$\endgroup$
1
$\begingroup$

libgl1-mesa-dev-lts-utopic has been moved to xenial:release repository. See This. In order to install it follow this link or execute sudo apt-get install --install-recommends linux-generic-lts-xenial xserver-xorg-core-lts-xenial xserver-xorg-lts-xenial xserver-xorg-video-all-lts-xenial xserver-xorg-input-all-lts-xenial libwayland-egl1-mesa-lts-xenial xserver-xorg-dev-lts-xenial mesa-common-dev-lts-xenial libxatracker-dev-lts-xenial libgles2-mesa-dev-lts-xenial libgles1-mesa-dev-lts-xenial libgl1-mesa-dev-lts-xenial libgbm-dev-lts-xenial libegl1-mesa-dev-lts-xenial

And after succesfully completing it execute sudo apt-get install ros-indigo-desktop-full

EDIT: If you are reinstalling ros on the machine then do this-

sudo apt-get purge ros-indigo*
sudo apt-get autoremove
sudo apt-get install ros-indigo-desktop-full
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.