2
$\begingroup$

I have an iRobot Create 2 and I am connected to it with the 7-pin connector to a desktop machine via USB. Serial communication is working fine under that configuration. I can tell it to restart with ctrl-G and read the messages it sends back. On power up the serial port outputs the following:

2015-08-24-1648-L
r3-robot/tags/release-3.5.x-tags/release-3.5.4:6058 CLEAN

bootloader id: 4701 5652 7E52 3FFF
assembly: 3.5-lite
revision: 2
flash version: 10
flash info crc passed: 1

battery-current-zero 257

When I plug in the raspberry pi 3 board with a 7-pin connector to the on-board UART, I can communicate with the iRobot without issue. However, the iRobot starts to continuously sound "uh-oh" every few seconds (no other beeps follow) after about 20 or so seconds of powering up the raspberry pi until the robot enters sleep mode. The iRobot serial port outputs the following message to the raspberry pi every time the robot sounds "uh-oh"

4701 5652 7E52 3FFF
ERROR: language set error type 2

Does anyone know what this error means?

My last resort is to scope the serial port from the raspberry pi to check for noise; unfortunately I don't have access to my scope at the moment.

$\endgroup$
2
$\begingroup$

Scope showed data being sent to the robot. I discovered the console was enabled on the raspberry pi 3 and disabled it; the problem is now resolved.

Specifically, run the following commands
sudo systemctl stop serial-getty@ttyS0.service
sudo systemctl disable serial-getty@ttyS0.service

Then edit /boot/cmdline.txt and remove the following option from the file

console=serial0,115200

Save and reboot. For more information see http://spellfoundry.com/2016/05/29/configuring-gpio-serial-port-raspbian-jessie-including-pi-3/

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.