2
$\begingroup$

I have installed and am trying to run a turtlebot package using gazebo and roslaunch.

Installation seems to have gone fine and I am now following the first tutorial, which just explains how to get the simulation started. The tutorial can be found here:

http://wiki.ros.org/turtlebot_gazebo/Tutorials/indigo/Gazebo%20Bringup%20Guide

I entered the command: source /opt/ros/indigo/setup.bash That seemed to go fine, there were no errors. Then I entered the command: roslaunch turtlebot_gazebo turtlebot_world.launch, which resulted in the following error log:

    while processing /opt/ros/indigo/share/turtlebot_gazebo/launch/includes/kobuki.launch.xml:
    Invalid  tag: Cannot load command parameter [robot_description]: command [/opt/ros/indigo/share/xacro/xacro.py '/opt/ros/indigo/share/turtlebot_description/robots/kobuki_hexagons_asus_xtion_pro.urdf.xacro'] returned with code [1]. 

    Param xml is (param command="$(arg urdf_file)" name="robot_description"/)
    The traceback for the exception was written to the log file

I tried asking on the ROS Answers website first but got no answer, so I'm hoping the good people of Stack Exchange can help me figure out what is causing this problem.

Additional information: The version of ROS I have installed is Indigo, and I'm on Ubuntu 14.04

$\endgroup$
1
$\begingroup$

I've figured out what the problem was.

Ubuntu was running a non-default version of python that I had installed for a University python project a couple of years go. I deleted it and now the default version of python is being used, which has solved the problem.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.