8
$\begingroup$

I am attempting to upload a custom firmware to a Lego Mindstorms NXT and am having issues.

First of all, I'm attempting to use nxtOSEK, which would let me run C++ programs on it. The problem is, everytime I put it into firmware update mode, the download doesn't seem to actually occur.

What I mean by this is that, according to the output in my terminal (both Mac and Windows), the download was successful, however when the NXT reboots, I still see the normal logo (not nxtOSEK).

So, what I'm doing is first holding down the Reset button for a few seconds, then hitting the orange button, giving me that tic-tic-tic sound. Then I run the firmware update (either using the Windows NextTool or Mac OSX GUI NextTool) and attempt the download. I get a success message, yet the robot is still using the old firmware.

What could be the cause of this problem and how can I solve it?

$\endgroup$
  • $\begingroup$ Have you tried downloading the firmware to a different NXT brick? $\endgroup$ – shea Oct 31 '12 at 6:54
  • $\begingroup$ I have not, however this is a completely fresh unit.... $\endgroup$ – the_e Oct 31 '12 at 16:13
  • $\begingroup$ Still, some NXT bricks are faulty when you get them. I've not used the nxtOSEK firmware before, but I'll try loading it onto my own brick and see what happens. $\endgroup$ – shea Oct 31 '12 at 21:26
  • $\begingroup$ Ok thanks, I'll give that a shot the next time I'm in my lab. Fortunately we have more than one... $\endgroup$ – the_e Oct 31 '12 at 21:52
  • $\begingroup$ I've just had a look at the nxtOSEK website... are you using the enhanced NBC/NXC firmware? (As in lejos-osek.sourceforge.net/howtoupload.htm#UploadToNXTfw and bricxcc.sourceforge.net/firmware.html) $\endgroup$ – shea Nov 1 '12 at 2:43
2
$\begingroup$

The reason why you can't see the nxtOSEK logo, is that the enhanced firmware looks the same as the regular firmware, but with several performance and feature enhancements. It isn't specific to nxtOSEK.

To check if the firmware installed properly, visit the Settings menu on the NXT, and then the NXT Version submenu. The top line should read: FW NBC/NXC x.xx, where x.xx is the version number of the firmware.

$\endgroup$
  • $\begingroup$ Hmm, it does show FW NBC/NXC 1.07. I guess I did flash it (in the tutorials/documentation I read, I always saw the nxtOSEK logo). I'm having issues running compiled C++ programs and figured the firmware didn't get updated. $\endgroup$ – the_e Nov 1 '12 at 14:46
  • 1
    $\begingroup$ @espais You can try grabbing the latest enhanced firmware from bricxcc.sourceforge.net/test_releases $\endgroup$ – shea Nov 1 '12 at 20:22
  • $\begingroup$ I'll give that a shot. If I continue to have problems I'll create a new question. Thanks! $\endgroup$ – the_e Nov 1 '12 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.