0
$\begingroup$

I am trying to help my son program his robot using RobitC graphical. He has it doing most of what he wants it to do but the code is stuck and won't continue past the arm raise/ hold. What it is supposed to be doing at the point where it gets stuck is raise the arms (to lift an object) Hold the arms up while reversing Turn 90 degrees Reverse (This is as far as he's created as he realized it isn't working) Turn 90 degrees Reverse to the basket and raise the arms again

His code is trying to say to hold the arms up until he creates a new set point

He has tried both of these codes

I know it says (left drive) instead of (arm) on one bit that was corrected and still doesn't work correctly

I was asked in the comments on my other question to post which line it fails. I believe it fails at 18. The arms stay up but the bot does not continue the program (reverse). I could not respond in the comments as I do not have a high enough rating. enter image description hereenter image description here

$\endgroup$
  • 1
    $\begingroup$ Welcom to Robotics Stephanie Beck. It looks like you may have accidentally created two accounts (Stephanie Beck & Stephanie). Stack Exchange only allows an individual to actively use one account, so please follow the instructions at I accidentally created two accounts; how do I merge them? Note that moderators can't merge accounts for you. $\endgroup$ – Mark Booth Feb 27 '17 at 12:30
  • 1
    $\begingroup$ Also, it is better to edit your question to add information requested in comments, rather than creating a new question. I guess this is a consequence of losing access to the first account you created, but you could also have suggested an edit to your original question, rather than adding another question. $\endgroup$ – Mark Booth Feb 27 '17 at 12:34
1
$\begingroup$

In both of the pictures, line 19 has a "wait" command. The execution of the program will progress past this line when the condition in the parenthesis has been met. You mentioned, that you have changed Ldrive to Larm and Rdrive to Rarm, however the motor brakes for these motors are set only after line 19. The command at line 19 is waiting for the brakes to be active, but there has been no command issued which would activate the brakes.

I would suggest that you try moving the set brake commands for the Larm and Rarm before the waituntil command.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.