0
$\begingroup$

I am working with turtlebot4 on an object detection project. I want to access its oak-d camera on my workstation.

The issue I face is, when I do ros2 topic list on my workstation, the camera topics - turtle1/oakd/rgb/preview/image_raw and turtle1/oakd/rgb/preview/camera_info does not show up. That is the oakd node is not active on my workstation.

But, when I ssh into the rapsberrypi of the turtlebot4 and do ros2 topic list, the above two camera topic shows up and oakd node is active.

I have attached screenshots of both the terminal windows. (workstation and rapsberrypi)

Some information about my setup: My workstation runs Ubuntu 22.04 and ROS2 Humble version. Network setup between my robot and workstation is WiFi with 5GHz. Simple Discovery connection with CycloneDDS

RMW_IMPLEMENTATION = rmw_fastrtps_cpp

Your help to understand and debug my issue is much appreciated. Thank You!

enter image description here

$\endgroup$
1
  • $\begingroup$ Please clarify if your system is running Cyclone DDS or Fast DDS. You mention Cyclone but then quote the RMW Implementation as Fast DDS. From the picture, your computer is only seeing topics from the create 3 while the pi can only see topics from itself (not the create 3). This likely points towards an issue with your ROS configuration (RMW Implementation or ROS Domain ID etc). If you aren't able to figure it out then please provide the full setup.bash's from your PC and the Raspberry Pi (at /etc/turtlebot4/setup.bash) as well as a picture of the configuration page from the create 3. $\endgroup$
    – Hilary Luo
    Commented Jun 25 at 4:05

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.