0
$\begingroup$

Im trying to use ROS for the first time with a project that needs to use visual slam with a mono camera input. I am using ROS1 Melodic with the orb_slam_2 package along side turtle bots to get a basic demo going. I was following along this guide I have linked here, when I start up the mono input with the command below on the burger robot in turtlebot house

roslaunch orb_slam2_ros orb_slam2_r200_mono.launch

It starts fine claiming that

Map point vector is empty!
Map point vector is empty!

so I drive the robot around the room until it starts detecting but the issue is it produces the following warning

[ WARN] [1718654957.763400620, 260.126000000]: "camera_link" passed to lookupTransform argument target_frame does not exist. 
[ WARN] [1718654957.763899781, 260.126000000]: "camera_link" passed to lookupTransform argument target_frame does not exist. 
[ WARN] [1718654958.011764224, 260.319000000]: "camera_link" passed to lookupTransform argument target_frame does not exist. 
[ WARN] [1718654958.012044564, 260.319000000]: "camera_link" passed to lookupTransform argument target_frame does not exist. 

And I cannot seem to get it to visualise at all to rviz. This has been the only decent guide I have found to setting it up and feel like I'm at the last hurdle to getting visual slam working but cannot understand what is going wrong here.

Terminals running commands

RVIZ setup

$\endgroup$

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.