I hope you are all well. I began dabbling with Robotis Ros a few weeks ago and just got my hands on a 2018 model turtlebot3 burger. It has a Raspberry Pi model 3b 1gb, 16gb memory, and hfs-lds-01 LiDAR for accessories. I followed the instructions on turtlebot3's website, downloaded Ubuntu 20.04, and decided to go with ros2 foxy. I ensured that everything was compatible and successfully ran teleop via SSH.

Pre: I did follow the instructions to "install lds-02 package" and in place of lds-02 package links, I used the lds-01 ones. I found this package on robotis github and am wondering if I needed to do this step in the first place. I would appreciate feedback on my decision here. It involved deleting the cartographer file and rebuilding.

Now I have a question. Under this section, I saw the turtlebot3 video for setting up the topic monitor and viewing it from rqt. Now I don't know if I'm wrong in understanding but was I supposed to run the ros2 bringup on the raspberry pi via ssh and then run rqt on my computer? This step is a little confusing as I tried to run rqt on my computer, then went into plugin > Topics > Topic Monitor, and could only see 2 topics in the monitor. I felt that it was obvious that I would only see these since my PI has the turtlebot topics running. So I tried typing rqt in the SSH and saw an error saying it is not installed in the Raspberry Pi.

Guys, please help me understand where I am going wrong. How can I view the topics on rqt on my computer while running turtlebot3 bringup on the Raspberry Pi? Without figuring this out, I cannot proceed to the SLAM section since it uses knowledge from here.

Thanks in advance!


1 Answer 1



I was having trouble connecting the VM Ubuntu to the same internet network. By this, I mean the VM had a different IP address than the PC it ran on, so when I tried pinging it from the Raspberry Pi, I would not see any response.

To solve this, I created a partition on my laptop and sideloaded Ubuntu on the PC so that this version of Ubuntu would be connected to the network directly. It is a brute method of working out the error, but it worked, although I had to re-install all the files on the platform.

Everything works now; if you seem to encounter this issue, this is a guaranteed fix.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.