1
$\begingroup$

OS:

Distributor ID: Ubuntu
Description:    Ubuntu 20.04.6 LTS
Release:        20.04
Codename:       focal

I installed pylon_7.5.0 and was able to build the pylon_camera package as described here. I can start the camera in Pylon, but when I run roslaunch pylon_camera pylon_camera_node.launch it cannot detect any camera (see below). I'm not even sure what should I try next.

user@user-desktop:~/Documents/basler_ws$ roslaunch pylon_camera pylon_camera_node.launch
... logging to /home/user/.ros/log/c2d2549a-1d18-11ef-b48c-8b0d7734e9b5/roslaunch-user-desktop-96721.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://user-desktop:35699/

SUMMARY
========

PARAMETERS
 * /pylon_camera_node/camera_frame: pylon_camera
 * /pylon_camera_node/camera_info_url: 
 * /pylon_camera_node/device_user_id: 
 * /pylon_camera_node/frame_rate: 5.0
 * /rosdistro: noetic
 * /rosversion: 1.16.0

NODES
  /
    pylon_camera_node (pylon_camera/pylon_camera_node)

auto-starting new master
process[master]: started with pid [96729]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to c2d2549a-1d18-11ef-b48c-8b0d7734e9b5
process[rosout-1]: started with pid [96739]
started core service [/rosout]
process[pylon_camera_node-2]: started with pid [96746]
[ WARN] [1716917766.080147954]: Autoflash: 0, line2: 1 , line3: 1 
[ INFO] [1716917766.080876560]: No Device User ID set -> Will open the camera device found first
[ERROR] [1716917766.388008856]: No camera present
[ INFO] [1716917768.388594042]: using default calibration URL
[ INFO] [1716917768.388755710]: camera calibration URL: file:///home/user/.ros/camera_info/camera.yaml
[ INFO] [1716917768.388967803]: Unable to open camera calibration file [/home/user/.ros/camera_info/camera.yaml]
[ WARN] [1716917768.389047499]: Camera calibration file /home/user/.ros/camera_info/camera.yaml not found.
^C[pylon_camera_node-2] killing on exit
^C[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

UPDATE

the manual and error suggests that the package opens either a predefined camera (using a given device_user_id parameter) or, if no camera id is predefined the first camera device it can find. Regardless, I tried setting the device_user_id just in case, but it didn't help.

$\endgroup$
0

1 Answer 1

1
$\begingroup$

It appears that the ethernet and wifi cards were on the same network and for some reason interfered with pylon discovery of the devices. Once I put the ethernet card on a different network pylon was able to discover the camera.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.