0
$\begingroup$

I am trying to install the Universal_Robots_ROS2_Driver package. When following the step 2 Start and Set up, they have mentioned to a way to extract the calibration. However, I tried to clone this UR_Calibration package using git clone -b iron https://github.com/UniversalRobots/Universal_Robots_ROS_Driver/tree/master/ur_calibration. Which gave me this error. fatal: could not create work tree dir 'ur_calibration': Read-only file system. Then I tried again to clone the whole package using git clone -b iron https://github.com/UniversalRobots/Universal_Robots_ROS2_Description.git and it gives the same error. I am unable to use the given script for UR calibration due to this error.

Can you please give me the hidden steps leading to use the script

roslaunch ur_calibration calibration_correction.launch \
robot_ip:=<robot_ip> target_filename:="${HOME}/my_robot_calibration.yaml

Please advice me the way to clone packages from github correctly. Thanks.

$\endgroup$

1 Answer 1

0
$\begingroup$

You are mixing ROS and ROS 2 versions. roslaunch is from ROS, and Universal_Robots_ROS_Driver is also for ROS (use Universal_Robots_ROS2_Driver for ROS 2)

can you create a folder where you run the git command? The error has nothing to do with ROS.

$\endgroup$
1
  • $\begingroup$ Thank you for your response and pardon my late reply as I was away for sometime. I tried with Ros2 driver and now I managed to clone all successfully. However when I tried to extract the calibration information from the real robot using the command $ ros2 launch ur_calibration calibration_correction.launch.py \ robot_ip:=<robot_ip> target_filename:="${HOME}/my_robot_calibration.yaml", I get an error "No such file or directory". Could you guide me ? $\endgroup$
    – Ann_u
    Commented Jun 7 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.