0
$\begingroup$

I am trying to install the package ros-noetic-ros-navigation, but when running

sudo apt-get install ros-noetic-ros-navigation

I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-noetic-ros-navigation

I tried running sudo apt update, which didn't change anything.

I can't seem to find a solution for this anywhere.

$\endgroup$

2 Answers 2

0
$\begingroup$

Its ros-noetic-navigation.

sudo apt-get install ros-noetic-navigation
$\endgroup$
0
$\begingroup$

When you cannot install the package you expect to be there, use apt search with just a fragment of the name to locate its exact name. You can grep by 'ros' to get less bulky output:

apt search navigation | grep ros

This lists various packages containing the keyword, and between them I see

ros-noetic-navigation/focal
ros-noetic-navigation-experimental/focal

that means you have likely misspelled the name.

Another answer also says the same, but I tried to provide methods for determining the package name when is not known with certainty.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.