In a vmware fusion 13 pro, a 4-core 4gm memory ubuntu 22.04 Vm I installed ros-humble and I'm trying to install gazebo 11 classic. I followed the steps from: https://classic.gazebosim.org/tutorials?tut=install_ubuntu&cat=install and ran the command:

curl -sSL http://get.gazebosim.org | sh

which gave me the following errors:

enter image description here

I checked out the following links for fixes but none of them worked:


Unable to install ros-gz on my Ubuntu 22.04 machine with ROS2 Iron already installed

Is there a fix for this? Thank you in advance!

  • $\begingroup$ Please paste any code or console output as code formatted text and not as a screenshot. Screenshots are not text searchable, amongst other things... $\endgroup$ Commented May 7 at 8:09

1 Answer 1


I might be wrong but doesn't sudo apt install ros-humble-desktop include Gazebo ?

And I gotta ask, is your device ARM or x64? I know that using gazebo-classic might be an issue with ARM based hardware. If so, I suggest trying gz-sim.

  • $\begingroup$ My device is arm64 and the sudo apt command didn't do it. I checked out online and tried directly installing from source following using: classic.gazebosim.org/… github.com/ros-simulation/gazebo_ros_pkgs/tree/ros2 still it kept failing $\endgroup$ Commented May 10 at 17:10
  • $\begingroup$ Did you installed it via "git clone <pkg_url> -b <branch_name>" command - and then compiled your workspace? What error message did it give? Could you detail it a bit more? $\endgroup$ Commented May 11 at 23:23
  • $\begingroup$ I'm sorry I'm new to this. I used wget command to retrieve the files and it worked but then when I followed the steps from the above gazebo link (classic.gazebosim.org/…, I'm getting this error: ibb.co/fN8DKrf $\endgroup$ Commented May 13 at 1:30
  • $\begingroup$ I haven't seen that error, "c++: fatal error: Killed signal terminated program cc1plus" before. Now I looked it up and it seems that the issue might be related to your hardware. Your PC might have run out of RAM and to overcome this you can increase swap partition, at least that's what they offer as a solution. Could you monitor your system memory while compiling and make sure of if this is the cause? Here is the related link: github.com/moveit/moveit2/issues/1276 $\endgroup$ Commented May 13 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.