0
$\begingroup$

OS: RaspberryPi OS

debian version: 11 (code name is bullseye.)

ROS2 version: humble

I tried to install the library with sudo apt install ros-humble-tf-transformations and sudo pip3 install transforms3d to use tf_transformations module in ROS2.

However, I got following error:

pi@raspberrypi:~ $ sudo apt install ros-$ROS_DISTRO-tf-transformations
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package ros-humble-tf-transformations

The ROS2 version is correct in Humble. Is there a solution? Thank you.

$\endgroup$
6
  • $\begingroup$ Please edit your question to include what OS are you running on? What distro, version and architecture? Also how have you setup your sources? $\endgroup$
    – Tully
    Apr 18 at 8:34
  • $\begingroup$ I edited my question. I'm running on RaspberryPi OS. I tried same thing on another computer with ubuntu 22.04 installed, and this one was able to install the package without error. Is it possible that the OS is doing something wrong? $\endgroup$
    – Kimura
    Apr 18 at 12:52
  • $\begingroup$ In general raspberry pi OS isn't a supported platform. However depending on which Debian version it is based on there may be compatibility. What is your specific version and architecture? What instructions are you following to install on this system that makes you expect that humble is available? And have you added ROS sources? $\endgroup$
    – Tully
    Apr 18 at 22:55
  • $\begingroup$ My debian version is 11 (code name is bullseye). After the RaspberryPi OS setup was complete, Humble was installed with wget https://s3.ap-northeast-1.wasabisys.com/download-raw/dpkg/ros2-desktop/debian/bullseye/ros-humble-desktop-0.3.1_arm64.deb and sudo apt install -y ./ros-humble-desktop-0.3.1_arm64.deb. I also installed the build tool with sudo pip install vcstool colcon-common-extensions. (I cited the following site. Sorry, it is in Japanese. zenn.dev/array/books/5efdb438cf8be3/viewer/8b105c) $\endgroup$
    – Kimura
    Apr 19 at 12:38
  • $\begingroup$ I additionally noticed that other tools, such as slam-toolbox and navigation2, also could not be installed by using sudo apt install ros-humble-<package_name>. $\endgroup$
    – Kimura
    Apr 19 at 13:04

1 Answer 1

0
$\begingroup$

I think Tully is correct. You have installed ROS2 desktop from source. Then you will also need to locate tf-transformations package and install it from source. Today I have installed TF transformations and pip transformations 3D in my ROS2 Iron and used in a script, it works. However my ROS2 installation is from pre-compiled package, binary, not from source.

To install in your raspberry you need:

Clone this repo:

https://github.com/DLu/tf_transformations

and just compile it on raspberry

cd ~/ros2_ws/src

git clone https://github.com/DLu/tf_transformations.git

cd ..

rosdep install --from-paths src --ignore-src --rosdistro humble -y

colon build

source install/setup.bash

To check if the package was correcly installed you can issue:

ros2 pkg list

Or

ros2 pkg list | grep tf_transformations

To Locate the installation directory:

ros2 pkg prefix tf_transformations

And for transforms3d:

pip3 show transformations3d
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.