I am having trouble to remotely control the UR5e robot arm using code. I am using ROS Noetic and trying to run test_move.py present in Universal Robots' repository in the following link: https://github.com/UniversalRobots/Universal_Robots_ROS_Driver/blob/master/ur_robot_driver/scripts/test_move#L148

The program blocks when initializing the node in line 85 (rospy.init_node("test_move")), and no log nor error message is given. I tried running it with rosrun as well as with python3 commands with no success.

Currently, I am able to control it using rostopic pub /ur_hardware_interface/script_command as well as locally. However, I would like to control it using a programable library. I have already tried rospy, roslibpy, urx and rclpy but with no success.

I would be extremely grateful if you can help me or point me in the right direction.

  • $\begingroup$ When you say remotely, do you mean from a machine that's not running the main ROS nodes? Are your machines all running the same OS/distro? And have you correctly set your ROS_MASTER_URI? $\endgroup$
    – BTables
    Commented Apr 11 at 14:57


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.