0
$\begingroup$
siddarth@siddarth-pi:~/sidli$ rosdep install --from-paths src -y --ignore-src
executing command [sudo -H apt-get install -y ros-humble-gazebo-ros2-control]
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package ros-humble-gazebo-ros2-control
ERROR: the following rosdeps failed to install
  apt: command [sudo -H apt-get install -y ros-humble-gazebo-ros2-control] failed
siddarth@siddarth-pi:~/sidli

I am using raspberry pi 4 model B and trying to setup ros2 humble but i encountered this error while i run the rosdep command I would highly appreciate any assistance with this.

$\endgroup$
3
  • 1
    $\begingroup$ Which ubuntu are you using? have you run apt-get update before? $\endgroup$ Commented Apr 10 at 19:48
  • $\begingroup$ Hi..am using ubuntu 22.04 lts and yes i have tried everything...i install rosdep but still it shows package not found...i guess the package was built for amd and since raspberry pi is arm64 am unable to install it....is there any other method?? $\endgroup$
    – Siddarth R
    Commented Apr 11 at 17:47
  • $\begingroup$ A general question is, why do you want to install gazebo on the RPi? $\endgroup$ Commented Apr 12 at 7:35

1 Answer 1

1
$\begingroup$

Gazebo is not available on arm64 so dependencies of gazebo including ros-humble-gazebo-ros2-control are not going to be available on arm64 either.

You can try compiling from source, and see if you can work around the blocker for the arm64 build. I don't know what the exact blocker is.

I checked the status here: https://repo.ros2.org/status_page/ros_humble_ujv8.html?q=ros2_control

Following the links back you can see gazebo_ros failing to build here due to gazebo not being installable.

https://build.ros2.org/view/Hbin_ujv8_uJv8/job/Hbin_ujv8_uJv8__gazebo_ros__ubuntu_jammy_arm64__binary/

23:25:14 The following packages have unmet dependencies:
23:25:14  ros-humble-gazebo-dev : Depends: gazebo but it is not installable
23:25:14                          Depends: libgazebo-dev but it is not installable
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.