0
$\begingroup$

I tried to run PX4 SITL simulation with gazebo-classic but get a core dumped error: enter image description here

I started with gdb and got further information: enter image description here

It seems that something wrong occurred with Boost.Asio and gzserver. I reinstalled the Boost library and gazebo but it still doesn't work. I use Ubuntu20.04 and gazebo 11.14.0, and gazebo can run perfectly standalone without px4. The version of Boost library is enter image description here

Can anyone help solve this issue? Thanks very much!

$\endgroup$
3
  • $\begingroup$ Please paste any code or console output as code formatted text and not as a screenshot. Screenshots are not text searchable, amongst other things... $\endgroup$ Apr 3 at 8:01
  • $\begingroup$ Sorry, I ran the simulation by command make px4_sitl gazebo, and the console output was .../sitl_run.sh: line 147: 548717 Segmentation fault (core dumped) gzserver $verbose $world_path $ros_args. I started with gdb and got further information: Thread 53 "gzserver" received signal SIGSEGV, Segmentation fault. [Switching to Thread 0x7fff31bf8700 (LWP 551511)] boost::asio::detail::reactive_descriptor_service::reactive_descriptor_service ( context=..., this=0x7ffef496bc68) at /usr/local/include/boost/asio/detail/impl/reactive_descriptor_service.ipp:39 39 reactor_.init_task(); $\endgroup$
    – Wen Li
    Apr 3 at 11:17
  • $\begingroup$ Please edit your question and put any additional details there, and not in the comments. Most of the formatting is lost in the comments and makes it very difficult to read. $\endgroup$ Apr 3 at 11:26

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.