0
$\begingroup$

you guys are my last straw :)

I just started using ROS2 together with Webots. I downloaded ros-humble-webots-ros2 and Webots2023b and launched my scipt with

ros2 launch vacusim_robot_driver simple_arena_launch.py.

Webots starts normally, but in the Webots Terminal i get this:

INFO: 'Custom_iRobot_Create' extern controller: Waiting for local or remote connection on port 1234 targeting robot named 'Custom_iRobot_Create'.
INFO: 'Custom_iRobot_Create' extern controller: connected.
INFO: 'Custom_iRobot_Create' extern controller: refusing connection attempt from another extern controller.
INFO: 'Custom_iRobot_Create' extern controller: disconnected, waiting for new connection.

If I look in my Ubuntu Terminal i get this:

[INFO] [launch]: All log files can be found below /home/name/.ros/log/2024-03-19-18-32-52-532359-name-HP-Spectre-x360-Convertible-13-ae0xx-21546
[INFO] [launch]: Default logging verbosity is set to INFO
WARNING: No valid Webots directory specified in `ROS2_WEBOTS_HOME` and `WEBOTS_HOME`, fallback to default installation folder /home/name/.ros/webotsR2023b/webots.
[INFO] [webots-1]: process started with pid [21547]
[INFO] [driver-2]: process started with pid [21549]
[driver-2] Cannot find any instance of Webots, retrying for another 50 seconds...
[driver-2] [WARN] [1710869576.642505189] [Custom_iRobot_Create]: Passing robot description as a string is deprecated. Provide the URDF or Xacro file path instead.
[ERROR] [driver-2]: process has died [pid 21549, exit code 1, cmd '/opt/ros/humble/lib/webots_ros2_driver/driver --ros-args --params-file /tmp/launch_params_0b0i1f1f'].

I searched for hours on the internet and just cant get behind the mistake I made, thats why I decided to ask the pros :) Maybe somebody can help me.

$\endgroup$
2
  • $\begingroup$ As a sanity check: Have you checked the env vars with echo $ROS2_WEBOTS_HOME and echo $WEBOTS_HOME, and the contents of those directories? Where are your webots actually stored? Do these locations match? $\endgroup$ Mar 19 at 20:45
  • $\begingroup$ As I understood it you dont really need it. If you dont calibrate these directories it will just use the standard directory. I think it connects to the controller but somehow disconnects after :( $\endgroup$
    – g. h.
    Mar 20 at 16:30

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.