0
$\begingroup$

I'm relatively new to ROS and am struggling with a problem I'm hoping someone can help with.

I'm running ROS Noetic on a PI4 with Ubuntu.

The issue is that move_base seems to keep crashing every time I set a 2D nav goal in RVIZ. Prior to that it works fine with the amcl localization etc and 2D initial pose setting in RVIZ. However it crashes with the same exit code error every time when I hit the 2D nav goal button. I've attached a screen shot of the error below. I can't for the life of me find anything about what exit code -9 means online after a lot of searching.

The move_base runs totally fine until I set the nav goal.

When I try and view the log file, it isn't there so I can't get much more debug info about the error.

This issue has been driving me completely nuts so any help would be greatly appreciated!

Update:

Running Ubuntu 20.04.5, Python versions 2.7, 3, 3.8 and 3.9 installed.

Ros-serial Arduino node installed directly on Arduino board.

Note that the issue causing move_base to crash on nav goal set isn't anything to do with the Ros Serial error, that's just occurring because there is a mismatch in protocol versions and can be ignored (it doesn't actually affect anything as I can still control the robot fine via teleop twist node.) The issue is with the move base error and the -9 exit code.

I have no idea what that means and can't get any other debug info about it. All my transforms are correct. See actual terminal output below at the moment of crash after I hit the 2D nav goal button in RVIZ:

[move_base-12] process has died [pid 2396, exit code -9, cmd /opt/ros/noetic/lib/move_base/move_base odom:=odom_data_quat __name:=move_base __log:=/home/ubuntu/.ros/log/b26d20bc-e320-11ee-a6d9-1fe0b765446c/move_base-12.log].
log file: /home/ubuntu/.ros/log/b26d20bc-e320-11ee-a6d9-1fe0b765446c/move_base-12*.log

[ERROR] [1710544109.174954]: Mismatched protocol version in packet (b'~'): lost sync or rosserial_python is from different ros release than the rosserial client
$\endgroup$
2
  • $\begingroup$ I understand the thinking the ROS-Serial is not an issue because you can telop, but note that when you click on the nav goal button, move-base starts sending twist messages onto the same topic that telop does. And then you see an ERROR saying there is a protocol mismatch. I don't think your success with telop gives reason to assume that movebase and rosserial client are fully compatible. I'm not saying you're wrong, just that I don't understand where the confidence comes from. $\endgroup$
    – billy
    Commented Mar 16 at 17:54
  • $\begingroup$ - EDIT for above comment: actually move-base doesn't start sending twist when you click on the button, it starts after you actually click on the map and set the goal. In your issue, is it clicking on the nav goal button or actually thes setting the goal on the map that preceeds the issue? $\endgroup$
    – billy
    Commented Mar 16 at 19:24

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.