0
$\begingroup$

I’m pretty new to ROS, gazebo, and robotics software in general. But I use a Mac, which in my experience isn’t the best but it’s kind of my only option for now

I use a Linux virtual machine to run ROS and anything related to it. I’ve tried to use gazebo in that virtual machine but it seems that my virtualization tool (parallels) doesn’t support the graphics API that gazebo requires, so I have to use software rendering, which is pretty inefficient and slow. But I did get the connection between gazebo and ROS working inside of that machine in using the LiDAR example.

Now I’m trying to run gazebo in native macOS and ROS on the Linux virtual machine, and I want to run the ros_gz_bridge inside of the virtual machine, not in native macOS because as far as I know, I need ROS installed on the native machine, but I don’t feel comfortable disabling SIP (system integrity protection) just to do that, and I want to keep everything on Linux as much as possible so I can learn the OS.

I’ve tried my best on my own to get it to work, but I’ve only got as far as listing the gazebo topics in macOS and seeing that it asks me to let gazebo receive incoming connections and seeing an “unknown message” error showing up on the Linux virtual machine while trying to use the bridge command

Is this possible to do?

I’m considering running another macOS VM too if absolutely necessary and disabling SIP in there

$\endgroup$

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.