0
$\begingroup$

I am trying to import a 3D model of a Humanoid robot into Webots, I tried to import the whole model as an OBJ file using the CAD shape node or a shape node with a mesh node. Still, in both cases, the model is larger than the real model and I can't access any of the links or joints I need to move. I tried another way which is adding each link alone in the same manner and then attaching them to each other however the large-scale problem still arose. I saw a couple of tutorials that solved this problem by a scale option, but it doesn't appear to me for some reason. Does anyone how to solve the scale problem or have a better way to import the 3D files?

$\endgroup$

1 Answer 1

0
$\begingroup$

the scale parameter can be found within the Transform node, Webots uses the metric system and assumes that the input size of the mesh is in meters. You can avoid using scale by changing the units in the CAD from where you imported the model to use meters, instead of mm or whatever you are using.

A better way to import the meshes is to create your own proto, there is a tutorial in the documentation that shows you how to structure it or depending on the CAD where your robot is, look for an exporter that will do it for you, most of them are capable of exporting some VRML or URDF then you can use urdf2proto to have it in webots.

$\endgroup$
1
  • 1
    $\begingroup$ I am working on a closed loop robot so the urdf option isn't working for me , however I would search more in the proto creation. Thank you man. $\endgroup$ Feb 20 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.