0
$\begingroup$

I recently bought a Pi 5 for my project and unfortunately, discovered that ROS2 humble isn’t supported as a binary. I had a workspace to run a slam diff drive robot. I had it working fine and I just wanted to work on Pi 5. I tried used Docker on Raspbian with the humble image. Everything works fine, I can view topics, publish, subscribe them all, except for one issue. I have a RCLCPP publisher node that reads various sensor data from an ESP32 via serial and publishes them to several topics. When trying to use the libserial library on this node, it fails to read or write data. The port can be opened but no reading or writing. But libserial works just fine as a standalone cpp file I tried and so does miniterm. I disregarded this as a docker issue.

Yesterday I found Armbian Jammy for Pi 5. So I tried out the same setup from my Pi 4 again but this time without docker and I’m facing the same issue. Libserial works in a standalone cpp file and miniterm also works, just like in docker but somehow libserial while using with ROS isn’t.

Thinking this was a libserial issue, I also tried this package https://github.com/joshnewans/serial

The same code but using different functions. Here, the same issue persists but the error thrown is device reports readiness to write but nothing could be read. When using Libserial it was simply Input/Output error

Any help is appreciated

$\endgroup$

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.