The goal is simply to get my raspberry Pi 4 running Ubuntu 20.04 (64 bit) and ROS1/Noetic to use a raspberry Pi Camera.

Now there are many pages devoted to this questions and I have tried them all. I have encountered the missing module meal. I have downloaded and rebuilt the raspicam_node directly from ubiquity Robotics web site. I have tried a lot of things. And I have been here before. In fact buried in my memory is that the problem was connected with 64 bit which is why I included it in my intro above.

So googling for an answer isn't going to work.

Most recently I noticed that there is something called "vc_hack" inside the raspicam_node package. Cd'ing to that directory followed by make clean; make install made the mmal error go away only to be replaced now by a missing header file interface/vcos.h.

Do you know of a known-working-recently set of instructions or code to help me over this roadblock?



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.