0
$\begingroup$

I am running ros_gz_bridge to read some data from Gazebo, in particular I have run:

ros2 run ros_gz_bridge parameter_bridge /model/x500_vision_0/odometry@nav_msgs/msg/Odometry[gz.msgs.Odometry

[INFO] [1706113773.667589591] [ros_gz_bridge]: Creating GZ->ROS Bridge: [/model/x500_vision_0/odometry (gz.msgs.Odometry) -> /model/x500_vision_0/odometry (nav_msgs/msg/Odometry)] (Lazy 0)

The problem is that when I run

ros2 topic echo /model/x500_vision_0/odometry

I do not see any message published on the topic.

I have already checked that the name of the topic is correct, and when I run

gz topic -et /model/x500_vision_0/odometry

I can see the messages exchanged within Gazebo.

So why is the bridge not publishing the messages on the ROS2 network?

EDIT:

Some more info about my setup.

I am working with ROS2 Humble and with Gazebo Sim version 7.7.0:

 gz sim --version
Gazebo Sim, version 7.7.0
Copyright (C) 2018 Open Source Robotics Foundation.
Released under the Apache 2.0 License.

I have installed Gazebo trough the apt package provided with ros2:

sudo apt install ros-humble-ros-gz

The world that I am running is a custom world that includes some static objects and a quadrotor equipped with the odometry plugin.

It all run inside a Docker based on the image osrf/ros:humble-desktop

$\endgroup$
2
  • 1
    $\begingroup$ Can you provide more details about your system setup, such as Gazebo and ros_gz versions and how you installed them and which world you were running? $\endgroup$
    – azeey
    Jan 25 at 20:12
  • $\begingroup$ I edited my question adding some more details! I hope them to be useful! $\endgroup$ Jan 26 at 9:10

1 Answer 1

1
$\begingroup$

I solved the issue. I thought I was working with Gazebo Fortress, but a software I was working with installed Gazebo Garden instead.

When I installed the ros-gz-bridge from the apt repository, it installed only the supported package that is officially supported by ROS Humble, which is the Gazebo Fortress one.

I installed the ros-gz-bridge from sources and now the bridge is working as expected.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.