0
$\begingroup$

I am connected to a UR5 over the network, working on ROS2 humble, on Ubuntu 22.04

  • I set up the right host IP on the robot and robot’s IP in the launch file
  • I installed the external control urcap.
  • I tried with both enable/disable remote control, and with both local/remote control on teach pendant

then i run on one terminal:

ros2 launch ur_robot_driver ur_control.launch.py ur_type:=ur5 robot_ip:=192.168.1.102 launch_rviz:=true

After that, I run the program on the teach pendant of the robot with the external control (with the correct IP).

On another terminal I run:

ros2 launch ur_robot_driver test_scaled_joint_trajectory_controller.launch.py

On 3rd terminal i run:

ros2 launch ur_moveit_config ur_moveit.launch.py ur_type:=ur5e launch_rviz:=true

Rviz starts with the robot at the right position. I plan and execute a random trajectory. The plan which i plan and execute is visible in rviz and i get this output in 3rd terminal:

Completed trajectory execution with status SUCCEEDED
Solution was found and executed.
Plan and Execute request complete!

However the real robot does not move. There is no error in the terminals.

Any clue what could be the problem here?

Thank you in advance

$\endgroup$
3
  • 1
    $\begingroup$ Welcome to Robotics Stack Exchange! I noticed that you have been using ur5 and ur5e interchangeably. It is important to note that these are two distinct robots. Based on my understanding, you are most likely using ur5e. Please double-check and ensure that you have ur_type:=ur5e in all your commands to avoid any confusion. $\endgroup$
    – ravi
    Commented Nov 24, 2023 at 2:24
  • $\begingroup$ i used ur_type:=ur5 in my all command but i get the same error $\endgroup$ Commented Nov 24, 2023 at 4:57
  • $\begingroup$ You could also provide the output fron your terminals. Perhaps and info/warning messages couls help. $\endgroup$ Commented Mar 2 at 17:01

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.