I want to make my robot stop avoiding dynamic obstacles, want it to stop in front of them and wait until the path is clear. I came across this post: how-to-disable-obstacle-avoidance-on-dwa-planner. The answer to this post says that I need to take out the local path planner from move_base so that I could apply a tracking_pid algorithm. How can I take out the local planner? I tried to comment it on my move_base launch but it brings up the default planner. Tried to remove my local_costmap and local_planner params but it still works. How could I disable this planner so that only the tracking_pid would move my robot?

Thanks in advance.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.