I am trying to follow the nav2 basic tutorial from Nav2 - Getting started.

ros2 launch nav2_bringup tb3_simulation_launch.py headless:=False
  • ROS Distro = humble
  • Python version = 3.10
  • Ubuntu = 22.04

I am getting following error repetitively. Not sure what am I missing here.

I tried reinstall, restarts, use python virtual environment, export gazebo model path etc. Nothing worked so far. Any hints on how to debug this ?

[INFO] [gzserver-1]: process started with pid [22439]
[INFO] [gzclient-2]: process started with pid [22441]
[INFO] [spawn_entity.py-3]: process started with pid [22443]
[INFO] [robot_state_publisher-4]: process started with pid [22445]
[INFO] [rviz2-5]: process started with pid [22447]
[INFO] [component_container_isolated-6]: process started with pid [22449]
[robot_state_publisher-4] [INFO] [1700309346.181918745] [robot_state_publisher]: got segment base_footprint
[robot_state_publisher-4] [INFO] [1700309346.181968116] [robot_state_publisher]: got segment base_link
[robot_state_publisher-4] [INFO] [1700309346.181973536] [robot_state_publisher]: got segment base_scan
[robot_state_publisher-4] [INFO] [1700309346.181976946] [robot_state_publisher]: got segment camera_depth_frame
[robot_state_publisher-4] [INFO] [1700309346.181980146] [robot_state_publisher]: got segment camera_depth_optical_frame
[robot_state_publisher-4] [INFO] [1700309346.181983496] [robot_state_publisher]: got segment camera_link
[robot_state_publisher-4] [INFO] [1700309346.181986706] [robot_state_publisher]: got segment camera_rgb_frame
[robot_state_publisher-4] [INFO] [1700309346.181989856] [robot_state_publisher]: got segment camera_rgb_optical_frame
[robot_state_publisher-4] [INFO] [1700309346.181992946] [robot_state_publisher]: got segment caster_back_left_link
[robot_state_publisher-4] [INFO] [1700309346.181996056] [robot_state_publisher]: got segment caster_back_right_link
[robot_state_publisher-4] [INFO] [1700309346.181999016] [robot_state_publisher]: got segment imu_link
[robot_state_publisher-4] [INFO] [1700309346.182002026] [robot_state_publisher]: got segment wheel_left_link
[robot_state_publisher-4] [INFO] [1700309346.182005066] [robot_state_publisher]: got segment wheel_right_link
[spawn_entity.py-3] [INFO] [1700309346.483318042] [spawn_entity]: Spawn Entity started
[spawn_entity.py-3] [INFO] [1700309346.483558354] [spawn_entity]: Loading entity XML from file /opt/ros/humble/share/nav2_bringup/worlds/waffle.model
[spawn_entity.py-3] [INFO] [1700309346.484108479] [spawn_entity]: Waiting for service /spawn_entity, timeout = 30
[spawn_entity.py-3] [INFO] [1700309346.484322510] [spawn_entity]: Waiting for service /spawn_entity
[rviz2-5] [INFO] [1700309346.830518848] [rviz2]: Stereo is NOT SUPPORTED
[rviz2-5] [INFO] [1700309346.830575378] [rviz2]: OpenGl version: 4.6 (GLSL 4.6)
[rviz2-5] [INFO] [1700309346.882734199] [rviz2]: Stereo is NOT SUPPORTED
[spawn_entity.py-3] [ERROR] [1700309376.520432628] [spawn_entity]: Service %s/spawn_entity unavailable. Was Gazebo started with GazeboRosFactory?
[spawn_entity.py-3] [ERROR] [1700309376.520810042] [spawn_entity]: Spawn service failed. Exiting.
[ERROR] [spawn_entity.py-3]: process has died [pid 22443, exit code 1, cmd '/opt/ros/humble/lib/gazebo_ros/spawn_entity.py -entity turtlebot3_waffle -file /opt/ros/humble/share/nav2_bringup/worlds/waffle.model -robot_namespace -x -2.00 -y -0.50 -z 0.01 -R 0.00 -P 0.00 -Y 0.00 --ros-args'].

1 Answer 1


Make sure you have exported the both turtle model and gazebo path in the same terminal you are launching the package or include the below lines in the in the .bashrc file.

export TURTLEBOT3_MODEL=waffle

export GAZEBO_MODEL_PATH=$GAZEBO_MODEL_PATH:/opt/ros/<ros2-distro>/share/turtlebot3_gazebo/models

Similar issue found here.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.