0
$\begingroup$

I am using rosserial for my project. I run roscore fine but when I input: rosrun rosserial_python serial_node.py /dev/ttyACM0:

Nothing happens, not even an error message. Also, the terminal seems like it is running the command as I cannot input other commands and I cannot abort using ctrl+C (A screen capture is attached below). I'm not sure what this means or what it could imply. I know for sure my usb port is located in /dev/ttyACM0 , it's the address located on my Arduino IDE which works. Also the Arduino is fine as I tried it for other projects and it worked fine.

I'm using Ubuntu 20.04, and have ROS Noetic installed along with arduino IDE. This was the setup instructed prior to trying out hello world and my own project:

sudo apt-get install ros-noetic-rosserial-arduino

sudo apt-get install ros-noetic-rosserial

roscore

cd arduino/arduino-1.8.15/libraries

rosrun rosserial_arduino make_libraries.py .

It is worth noting that rosserial has been working fine for the past two years and this happened suddenly today so I was not sure what was the problem so I uninstalled it and re-installed it again using the steps above.

If there's any info needed to solve this, I'll be be happy to answer asap. It hurts I can't do the first tutorial

enter image description here

$\endgroup$
4
  • $\begingroup$ Because "this happened suddenly today" please edit your question to try to provide as much context about what else happened on your computer at the same time. As your problem is most likely a side effect of something else that happened on your system during that period. $\endgroup$
    – Tully
    Nov 4, 2023 at 8:48
  • $\begingroup$ Well there has been a lot going on recently with my Ubuntu so I did not really keep up with all the details but I will try to sum it up. For some reason, a week ago, I found my laptop ignoring the grub and opening windows 10 when I power up my laptop. I changed it in the bios menu and I did manage to open the Ubuntu. I then found out that my user was not a sudo user anymore and I needed to run in safe mode in order to be able to set my user as a sudo user again. $\endgroup$ Nov 4, 2023 at 9:59
  • $\begingroup$ Make sure, your user (not root) is in the dialout group $groups $\endgroup$
    – Wilhelm
    Nov 4, 2023 at 20:29
  • $\begingroup$ Please edit your question to show us the output of ls -ld /dev/ttyACM* (as regular text, not as a screen shot.) Also tell us what bitrate your arduino serial port is configured to use. $\endgroup$
    – Mike973
    Nov 6, 2023 at 21:57

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.