I am trying to use RVIZ2 on Windows 10 with ROS2 Humble, without much success so far. Running (after activating local_setup.ps1):

ros2 run rviz2 rviz2

Returns with the message:

[ros2run]: Process exited with failure 3221225595

When running the executable directly:


I get no messages at all, but the exit code is -1073741701.

I can reproduce this with Windows Sandbox (although the numbers are slightly different), with a fresh and default install of Humble.

ROS2 is working normally and I have installed Qt 5.12.12.
What could be the problem here?


2 Answers 2


For me, the solution was as Roberto said, but I also needed to copy some .dll files such as OgreMain.dll, OgreOverlay.dll, assymp-vc140-mt.dll, libcurl.dll, yam-cpp.dll, zlib.dll from C:/dev/ros2_humble/opt/{other folder}/bin to C:/dev/ros2_humble/bin and changing the name of the zlib.dll.


Partial answer already: I noticed that when I ran rviz2.exe directly from Explorer by double clicking I got a bunch of error dialogues about missing DLLs. Unsurprising, because it's missing the ROS2 environment.

So from the ROS2 environment I ran:

start C:\dev\ros2_humble\bin\rviz2.exe

(I did it without start ... before.) Now I got a meaningful error: I got a dialogue with a missing DLL for zlib1.dll. After searching I see that C:\dev\ros2_humble\opt\rviz_ogre_vendor\bin\zlib.dll does exist. So I created a symbolic link for the file zlib1.dll to solve this:

cd ...
mklink "zlib1.dll" "zlib.dll"

This fixed RVIZ2 on my PC!

In the sandbox I have more errors: "OpenGL 1.5 is not supported", but that is outside this scope.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.