0
$\begingroup$

I have made a new basement parking world model in blender before exporting it in different formats (dae, stl, obj ) destined for gazebo. The model is correctly imported in gazebo however, the sensors onboard my robot is not able to detect the pointclouds in 3D. The velodyne sensor in particular propagates circular concentric wavefronts as if the walls of the model are non existent (non visible) to it.

enter image description here enter image description here

    <?xml version="1.0" ?>
<sdf version="1.6">
  <model name="veolia_vxv">
    <static>true</static>
    <self_collide>false</self_collide>
    <link name="link">
      <collision name="collision">
        <geometry>
          <mesh>
            <scale>1.0 1.0 1.0</scale>
            <uri>model://veolia_vxv/meshes/veolia_2.stl</uri>
          </mesh>
        </geometry>     
      </collision>

      <visual name="visual">
        <geometry>
          <mesh>
            <scale>1.0 1.0 1.0</scale>
            <uri>model://veolia_vxv/meshes/veolia_2.stl</uri>
          </mesh>
        </geometry>
      </visual>
    </link>
  </model>
</sdf>

N.B 1:The model in blender has also been exported to obj, and dae, but no extensions seems to be working. N.B 2: Using the gazebo building editor, a different model works fine with my 3D sensors but the editor is very much limited in options for more elaborated models, the reason i switched to blender. The problem IMHO is coming either from blender or the model integration in ros/gazebo.

Any help will be very much appreciated.

$\endgroup$

1 Answer 1

0
$\begingroup$

SOLVED! The model should be placed in ~/.gazebo/models for it to be recognised by gazebo.

$\endgroup$
3
  • $\begingroup$ Glad you could fix it. Please mark your question as answered. $\endgroup$ Commented Oct 19, 2023 at 12:52
  • $\begingroup$ Can't find the "answered" tag :( $\endgroup$ Commented Oct 20, 2023 at 13:22
  • $\begingroup$ I think there should be a green tick next to your answer, isn't it? $\endgroup$ Commented Oct 21, 2023 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.