screenshot of gazebo simulation

Hello. I'm trying to make a simulation of moon surface on gazebo. I tried to use this git for importing moon surface model. https://github.com/MobileRobots/amr-ros-config/tree/master/gazebo/models/apollo15_landing_site_1000x1000 The problem is this. I succeeded to upload moon surface on gazebo, but the problem is the texture or color isn't correct. I thought it was problem of getting texture image is having a problem so I copied texture file from git link to usr/share/gazebo-11/media/materials/textures folder. Also I tried to change jpg file to png file, but nothing solves the problem. How can I change the color or texture of model? Thanks for reading and wishing I can solve the answer from your helps. For asking specific question, I'm uploading world code and sdf code


<light name='sun' type='directional'>
  <pose>0 0 10 0 -0 0</pose>
  <diffuse>0.8 0.8 0.8 1</diffuse>
  <specular>0.2 0.2 0.2 1</specular>
  <direction>-0.5 0.1 -0.9</direction>
<model name='ground_plane'>
  <link name='link'>
    <collision name='collision'>
          <normal>0 0 1</normal>
          <size>100 100</size>
    <visual name='visual'>
          <normal>0 0 1</normal>
          <size>100 100</size>
<gravity>0 0 -9.8</gravity>
<magnetic_field>6e-06 2.3e-05 -4.2e-05</magnetic_field>
<atmosphere type='adiabatic'/>
<physics type='ode'>
  <ambient>0.4 0.4 0.4 1</ambient>
  <background>0.7 0.7 0.7 1</background>
<state world_name='default'>
  <sim_time>32 252000000</sim_time>
  <real_time>32 474591156</real_time>
  <wall_time>1696991403 12767677</wall_time>
  <model name='ground_plane'>
    <pose>0 0 0 0 -0 0</pose>
    <scale>1 1 1</scale>
    <link name='link'>
      <pose>0 0 0 0 -0 0</pose>
      <velocity>0 0 0 0 -0 0</velocity>
      <acceleration>0 0 0 0 -0 0</acceleration>
      <wrench>0 0 0 0 -0 0</wrench>
  <light name='sun'>
    <pose>0 0 10 0 -0 0</pose>
<gui fullscreen='0'>
  <camera name='user_camera'>
    <pose>5 -5 2 0 0.275643 2.35619</pose>
  • $\begingroup$ Have a look at ~/.gazebo/server-XXXXX/gzserver.log, are there any hints? $\endgroup$ Commented Oct 16, 2023 at 13:31

1 Answer 1


I think it's from this path


The file:// suggests gazebo to look for this media/materials/textures/AS16-110-18026HR-512x512.jpg in the $GAZEBO_RESOURCE_PATH (but putting the texture file in /usr/share/gazebo-11/media/materials/textures should also work if you have sourced the setup.sh file from gazebo.)

Changing to


should work (there is a note about global gazebo path only in that file). Given the file is already 8 years old, I'm not sure what have changed on the heightmap format.

Another place to look for clues when it comes to the graphics is in ~/.gazebo/ogre.log. There should be some error about texture file not found there.

  • $\begingroup$ so sorry for such a late reply I've solved Thank you so much $\endgroup$ Commented Mar 15 at 1:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.