0
$\begingroup$

I am trying to install ros kinetic kame in ubuntu 16.04 , but after trying the first step setup your sources. list. I am getting cannot create /etc/apt/sources.list.d/ros-latest.list: Permission denied what to do now

$\endgroup$
2
  • $\begingroup$ We're going to need a little more detail. Where exactly in the process of installing KK are you when you get this error? Have you checked to make sure that you have the necessary permissions/are inputting the admin password when it prompts you? $\endgroup$ – MechanicalMan Aug 11 '16 at 18:42
  • 1
    $\begingroup$ this question might be better suited for answers.ros.org $\endgroup$ – holmeski Aug 11 '16 at 18:46
3
$\begingroup$

I understand that the problem was when running this command in the terminal:

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'

Could it be you forgot to run it with sudo?

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.