0
$\begingroup$

I am trying to upgrade my packages but when I run apt upgrade I am getting the following error:

E: Failed to fetch http://packages.ros.org/ros2/ubuntu/pool/main/r/ros-humble-rviz2/ros-humble-rviz2_11.2.7-1jammy.20230814.171234_amd64.deb  404  Not Found [IP: 2605:bc80:3010::134 80]

Did the gpg keys expired or got changed? I checked the github repo and the last change was 2 years ago, so I am not sure what is happening.

Any ideas?

BTW: I am using ubuntu 22.04 + ROS Humble

EDIT 1:

apt update output:

$ sudo apt update
Hit:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 https://download.docker.com/linux/ubuntu jammy InRelease                                                                                                          
Get:3 https://nvidia.github.io/libnvidia-container/stable/ubuntu18.04/amd64  InRelease [1.484 B]                                                                        
Hit:4 https://repo.steampowered.com/steam stable InRelease                                                                                                              
Hit:5 https://updates.signal.org/desktop/apt xenial InRelease                                                                                                           
Hit:6 https://ppa.launchpadcontent.net/graphics-drivers/ppa/ubuntu jammy InRelease                                                                                      
Hit:7 https://app.eduvpn.org/linux/v4/deb focal InRelease                                                                                                               
Hit:8 http://archive.ubuntu.com/ubuntu jammy InRelease                                                                                                                  
Hit:9 http://packages.ros.org/ros2/ubuntu jammy InRelease                                                                                              
Hit:10 https://ppa.launchpadcontent.net/pipewire-debian/pipewire-upstream/ubuntu jammy InRelease                
Hit:11 https://repo.vaticle.com/repository/apt trusty InRelease                           
Hit:12 http://archive.ubuntu.com/ubuntu jammy-updates InRelease     
Hit:13 http://packages.osrfoundation.org/gazebo/ubuntu-stable jammy InRelease
Hit:14 http://archive.ubuntu.com/ubuntu jammy-backports InRelease
Hit:15 http://archive.ubuntu.com/ubuntu jammy-security InRelease
Fetched 1.484 B in 1s (1.942 B/s)
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
73 packages can be upgraded. Run 'apt list --upgradable' to see them.

Solution

I had to manually delete the apt cache. I tried running apt clean but it didn't work.

sudo rm /var/lib/apt/lists/*
$\endgroup$
1
  • $\begingroup$ No, I don't think so: I believe this describes the last time that happened (and provides a solution). So you can certainly try that solution but I'd be checking that you can actually ping that server. $\endgroup$
    – cst0
    Sep 18, 2023 at 14:09

1 Answer 1

4
$\begingroup$

I think you just need to run a "sudo apt update" to get the latest versions of available Debians.

The file name you referenced does not currently exist on the server - but a version with the later build date code of 20230822 does exist - so I think your apt cache is out of date.

$\endgroup$
5
  • $\begingroup$ I did run sudo apt update before trying to upgrade. I am only having problems with ros packages. If I run apt upgrade --fix-missing it upgrades the non-ros packages $\endgroup$ Sep 18, 2023 at 14:47
  • 2
    $\begingroup$ I would suggest looking closely at the output/errors from your "apt update" command - something is going wrong there because the package you're trying to download is an older version, so the cache doesn't match what's actually on the server. $\endgroup$ Sep 18, 2023 at 15:48
  • $\begingroup$ There is nothing out of the ordinary in the apt update output. I updated the question with the output. By the way, I tried doing the same process from two different locations to make sure it is nothing related to my network setup. $\endgroup$ Sep 20, 2023 at 12:20
  • $\begingroup$ Ok, I solved it. I manually deleted all the apt caches. I tried using apt clean but it didn't work. I updated the question with the solution. $\endgroup$ Sep 20, 2023 at 12:26
  • $\begingroup$ Thanks for the help! $\endgroup$ Sep 20, 2023 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.