0
$\begingroup$

I really want to ask you about the UM7 Orientation Sensor we purchased. We want so much to use the UM7 in our research.

As it is mentioned on the Pololu website, the IMU transmits data using human-readable NMEA strings (up to 100 Hz broadcast), binary packets for higher efficiency (up to 255 Hz broadcast), or a combination of both.

We know it is default configuration at 20 Hz, how do we change it to 100 Hz or the 255 Hz max? Using the Windows program Redshfit Serial Interface Software/CH Robotics Software, we were able to change the broadcast rate for the processed data at 255 Hz and the graph shows at 255Hz (we think)...But if we start recording the data it only gives 20 Hz (how do we know this? When we check the .csv log it only gives 20 rows of data in 1 sec... We expect that it should show 255 rows of data in 1 sec). Any suggestions?

We tried working on various different approaches too. We tried the ROS driver version, Windows program versions, but to no avail. We get this issue that many others get:

When I start the um7_driver it tells me its running at 255Hz:

[ INFO] [1471034280.126928398]: um7_driver successfully connected to serial port /dev/ttyUSB0.
[ INFO] [1471034280.131541907]: Received packet 02 without data.
[ INFO] [1471034280.133519679]: Setting update rate to 255Hz
[ INFO] [1471034280.137407860]: Received packet 02 without data.
[ INFO] [1471034280.143123357]: Received packet 04 without data.
[ INFO] [1471034280.149176752]: Received packet 05 without data.
[ INFO] [1471034280.159062327]: Received packet 06 without data.
[ INFO] [1471034280.165085744]: Received packet 08 without data.
[ INFO] [1471034280.165672434]: Sending command: zero gyroscopes
[ INFO] [1471034280.573718137]: Received packet ad without data.

However, 'rostopic hz' tells me that the data is being published at only around 45 Hz:

will@ubuntu:~/evae_ws/src/um7/src$ rostopic hz /imu/rpy
subscribed to [/imu/rpy]
average rate: 46.627
    min: 0.011s max: 0.040s std dev: 0.01241s window: 43
average rate: 46.173
    min: 0.011s max: 0.040s std dev: 0.01235s window: 90
average rate: 45.560
    min: 0.011s max: 0.058s std dev: 0.01265s window: 135

This was asked on the ROS website - https://answers.ros.org/question/241646/getting-euler-angles-to-publish-at-255hz-from-the-um7_driver/.

Is the made Windows software better? If so how do we log at 255 Hz in our .csv?

If this ROS way is better, any suggestions here to fix?

$\endgroup$

1 Answer 1

1
$\begingroup$

Have you updated the baudrate? It may be targeting your desired update rate but be limited by the baudrate. See the discussion here: https://github.com/ros-drivers/um7/issues/17#issuecomment-363263312

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.