0
$\begingroup$

I am working on a project where a remote in a Jetson Nano on an RC-Car from my Laptop to run ROS2 Nodes. So far everything is working fine despite of this warning, but i'm wondering if it can lead to problems later on.

Below is the demo talker node:

anassq@anassq-ThinkPad:-$ ros2 run demo_nodes_cpp talker
[INFO] [1693382772.600519335] [talker]: Publishing: 'Hello World: 1'
[INFO] [1693382773.600493124] [talker]: Publishing: 'Hello World: 2'
[INFO] [1693382774.600495367] [talker]: Publishing: 'Hello World: 3'
^C[INFO] [1693382775.563863256] [rcicpp]: signal_handler(signal_value=2)
anassq@anassq-ThinkPad:-$

Below is the demo listener node:

jetson@nano:—$ ros2 run demo_nodes_cpp listener
/opt/ros/foxy/bin/ros2:6: DeprecationWarning: pkg_resources is deprecated as an API. See https://setuptools.pypa.io/en/latest/pkg_resources.html
 from pkg_resources import load_entry_point
[INFO] [1693382772.604064646] [listener]: I heard: [Hello World: 1]
[INFO] [1693382773.596332466] [listener]: I heard: [Hello World: 2]
[INFO] [1693382774.595766385] [listener]: I heard: [Hello World: 3]
^C[INFO] [1693382891.440914460] [rcicpp]: signal_handler(signal_value=2)
jetson@nano:—$

Please Note: The Ubuntu image i flashed on the jetson-nano comes with already installer python and many other packages. Here is the source of that image: https://github.com/Qengineering/Jetson-Nano-Ubuntu-20-image

I tried updating the system and the rosdep, but it didn't work. Does anyone have a suggestion to how this could be solved ?

Thanks a lot for the read

$\endgroup$
1
  • $\begingroup$ Welcome to Robotics Stack Exchange! I could grab text from your screenshots and modify the question already. However, in the future, please note that it is better to paste the text from the error rather than a screenshot. Images are not text-searchable. $\endgroup$
    – ravi
    Aug 30, 2023 at 8:35

1 Answer 1

0
$\begingroup$

Welcome to Robotics Stack Exchange!

It is a warning coming from the colcon-core module of ROS 2. Please ignore it as it does not affect any functionality of ROS. Feel free to read more at https://github.com/colcon/colcon-core/issues/552

$\endgroup$
2
  • $\begingroup$ Hello, Thanks a lot ! for the read and for your answer. I managed on the last hour to solve it. By downgrading setuptools. $\endgroup$
    – Anass
    Aug 30, 2023 at 9:09
  • $\begingroup$ jetson@nano:~$ pip3 list | grep setuptools setuptools 68.1.2 And then: jetson@nano:~$ pip3 install setuptools==58.2.0 Defaulting to user installation because normal site-packages is not writeable Collecting setuptools==58.2.0 Downloading setuptools-58.2.0-py3-none-any.whl (946 kB) ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 946.1/946.1 kB 3.0 MB/s eta 0:00:00 Installing collected packages: setuptools +++++++++++++++++++++++++++++++++++++++++++++++ And then it was gone ! $\endgroup$
    – Anass
    Aug 30, 2023 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.