4
$\begingroup$

I am working on this project that involves using the Kinect for XBOX 360S with ROS.

I did all the steps mentioned in the ROS Tutorials to have Openni Installed and the Prime sense and other drivers. and when i go to Openni samples i see a output. But in ROS i do a roscore and in another terminal do a roslaunch openni_launch openni.launch. And it loads with the regular calibration warnings and service already registered errors. Then in another terminal i open Rviz which gives a error /.rviz/display_config does not exist. And even though i accept the error and go ahead i see a black window which shows no output ,even if i do all tasks mentioned at the RVIZ Tutorials. Also i tried running "rosrun image_view image_view image:=/camera/rgb/image_color" and it shows up a blank window with no output. How do i resolve this and get ros to show my kinect data??

I need to run RGBDSLAM and use this kinect later.

I am on Ubuntu 12.04 and ROS-Fuerte.

Well when i launch the openni.launch it starts as usual except for the errors ¨Tried to advertise a service that is already advertised in this node.

And when i run a rostopic it just says subscribed to the /camera/depth_registered/points and cursor keeps blinking. Even subscribing to the rectified topics just says subscribed and nothing more happens.

$\endgroup$
  • $\begingroup$ roslaunch will start a core if one does not already exist. I wonder whether starting roscore before executing roslaunch is causing trouble. Try executing roslaunch without first executing roscore. $\endgroup$ – DaemonMaker Mar 8 '13 at 19:28
  • $\begingroup$ Using roslaunch with roscore open should not cause a problem. I'd suggest running 'roswtf' and 'rxgraph' to make sure nodes are connected as they should be for a first pass. Also check this out to see if this is your problem. http://answers.ros.org/question/50730/rviz-start-up-error/ $\endgroup$ – brnd4n Mar 12 '13 at 3:13
  • $\begingroup$ @brnd4n On running roswtf i get 17 Errors "Communication with /camera/depth/metric/ failed. $\endgroup$ – Preetham Hegde Mar 12 '13 at 12:47
  • $\begingroup$ And on running rxgraph i get a graph in which all paths are pointing an arrow towards/rosout. $\endgroup$ – Preetham Hegde Mar 12 '13 at 12:48
  • $\begingroup$ To get a little more help with this, try posting your rxgraph and some other information. $\endgroup$ – Josh Vander Hook Mar 13 '13 at 15:29
4
$\begingroup$

Try freenect, there are some problems with OpenNI solution.

Firt, install freenect by

sudo apt-get install ros-fuerte-freenect-stack

After installation, connect your kinect (in USB 2.0 port) and run freenect

roslaunch freenect_launch freenect.launch

Then run Rviz and set Fixed frame to /camera_link, you can now add PointCloud2 window and select the right topic to view the input.

rosrun rviz rviz

Hope you enjoy ROS!

$\endgroup$
1
$\begingroup$

First of all, I know this is not an answer, however since I am a new user I cannot comment on Preetham's question.

I have a very similar problem, however, when I first run roswtf, I get no errors but when I wait a bit after using rviz or trying to record a bagfile, the openni.launch terminal itself gives me this error:

terminate called after throwing an instance of 'openni_wrapper::OpenNIException' what(): virtual void openni_wrapper::OpenNIDevice::startImageStream() @ /tmp/buildd/ros-groovy-openni-camera-1.8.8-0precise-20130418-2203/src/openni_device.cpp @ 224 : starting image stream failed. Reason: Xiron OS got an event timeout! [camera_nodelet_manager-2] process has died [pid 3788, exit code -6, cmd /opt/ros/groovy/lib/nodelet/nodelet manager __name:=camera_nodelet_manager __log:=/home/rosbotics/.ros/log/16b63744-e043-11e2-ac16-080027486aa8/camera_nodelet_manager-2.log]. log file: /home/rosbotics/.ros/log/16b63744-e043-11e2-ac16-080027486aa8/camera_nodelet_manager-2*.log

and roswtf displays:

unknown network error contacting node: timed out

Warning These nodes have died:

  • camera_nodelet_manager-2

found 2 errors

ERROR The following nodes should be connected but aren't:

  • /camera_base_link1->/camera_nodelet_manager (/tf)

  • /camera_base_link->/camera_nodelet_manager (/tf)

  • /camera_base_link3->/camera_nodelet_manager (/tf)

  • /camera_base_link2->/camera_nodelet_manager (/tf)

ERROR Errors connecting to the following services: (then it displays a lot of services)

At first After looking around a bit I thought it was a problem with openni and tried using freenect instead, however that too gave a black screen. Then I tried using something completely unrelated to ros, freenect-glview, however that too gave me a black screen.

lsusb shows that all 3 parts of the kinect are connected and I've been able to control the kinect's motor through ubuntu so I know that there is at least a connection established between both.

I am using ubuntu 12.04 and ROS-Groovy.

I would appreciate anyone's help on the matter.

$\endgroup$
  • $\begingroup$ Welcome to StackExchange and thanks for contributing. Read the "About" link near the search bar for a badge. $\endgroup$ – Devyn Collier Johnson Jul 21 '13 at 1:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.