0
$\begingroup$

Rosanswers logo

I try to connect to my UR3e via ROS 2. For this i installed ROS 2 Foxy. To connect to my UR, I installed the Universal Robot package

Now i have some issues, when i finally want to connect to the Robot. I installed the "externalcontrol-1.0.5.urcap" file on the teach pendant. The Pendant is running with the polyscope version 5.12.4. When i start

ros2 launch ur_bringup ur_control.launch.py ur_type:=ur3e robot_ip:=192.168.1.102 use_fake_hardware:=true launch_rviz:=true

i get following error:

[ERROR] [1664263597.180336063] [UR_Client_Library]: Failed to connect to robot on IP 192.168.1.102. Please check that the robot is booted and reachable on 192.168.1.102. Retrying in 10 seconds

Afterwards I start the URCap file on the Panel. There i get the following error

The connection to the remote PC at 192.168.1.110:50002 could not be established. Reason: connection time out

or

The connection to the remote PC at 192.168.1.110:50002 could not be established. Reason: No route to host (Host unreachable)

or

The connection to the remote PC at 192.168.1.110:50002 could not be established. Reason: Connection refused (Connection refused)

My ROS2 is running in VMware on Ubuntu 20.04. In my VM, I set up a additional network adapter. The already existing one is set to NAT. The new one is set to network bridge, where i chose the Realtek PCIe Gbe Family Controller which should be my Ethernet socket, where my LAN cable from the UR is connected to. The second Adapter has a static IP address: 192.168.1.110.

Pinging the UR from the virtual machine is possible:

64 bytes from 192.168.1.102: icmp_seq=1 ttl=128 time=1.56 ms

A Ping is possible if both network adapters are activated or just any of them.

Does any of you have a idea where the problem is and how to solve this?.


Originally posted by LucB on ROS Answers with karma: 42 on 2022-09-27

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Here the UR-Forum with the solution.

https://forum.universal-robots.com/t/connect-to-ur-with-ros2/24085


Originally posted by LucB with karma: 42 on 2022-10-04

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by gvdhoorn on 2022-10-05:
Could you please quote the relevant parts from that discussion so your answer here is stand-alone?

UR has made their fora only accessible to people with an account in the past (and then changed it back), which if it would happen again would make your link inaccessible. By copy-pasting the relevant parts here, we avoid that problem.

Comment by LucB on 2022-10-05:
Here we go

[ur_ros2_control_node-1] [FATAL] [1664881747.865636229] [URPositionHardwareInterface]: Variable 'speed_slider_mask' is currently controlled by another RTDE client. The input recipe can't be used as configured

There seems to be something else running on the robot using the RTDE input fields. Do you have a fieldbus activated? We had a section for that in the ROS1 driver’s README that seems not to have made it to the ROS2 driver.

This could also be caused by another URCap installed on the robot.

Let me add that we are currently working on replacing the requirement on RTDE inputs for most things, but we won’t be able to ditch the RTDE inputs completely in the near future.

Comment by gvdhoorn on 2022-10-05:
So what was the specific cause in your case?

Comment by LucB on 2022-10-05:
I hast to disable the EtherNet/IP like explained in the ROS1 driver‘s README.

Comment by gvdhoorn on 2022-10-05:
You mean EtherNet/IP, correct?

Comment by LucB on 2022-10-05:
ah, yes. changed that.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.