0
$\begingroup$

Rosanswers logo

After following: https://docs.ros.org/en/humble/Installation/Ubuntu-Install-Debians.html and doing a system upgrade, I am unable to install ros-humble-desktop-full or ros-rolling-desktop-full (see https://github.com/ros2/ros2/issues/1272):

$ sudo apt install ros-humble-desktop
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apt : Depends: libapt-pkg6.0 (>= 2.4.5) but it is not going to be installed
       Depends: libsystemd0 but it is not installable
 bsdutils : PreDepends: libsystemd0 but it is not installable
 dconf-gsettings-backend : Depends: dconf-service (< 0.40.0-3.1~)
                           Depends: dconf-service (>= 0.40.0-3)
 init : PreDepends: systemd-sysv
 libcolord2 : Depends: libudev1 (>= 196) but it is not installable
 libdbus-1-3 : Depends: libsystemd0 but it is not installable
               Recommends: dbus
 libgudev-1.0-0 : Depends: libudev1 (>= 199) but it is not installable
 libhwloc15 : Depends: libudev1 (>= 183) but it is not installable
 libignition-cmake2-dev : Depends: cmake
 libinput10 : Depends: libudev1 (>= 183) but it is not installable
              Depends: libinput-bin (>= 1.20.0-1ubuntu0.1)
 libopenmpi-dev : Depends: openmpi-bin (>= 3.0.0-1)
                  Recommends: libcoarrays-openmpi-dev but it is not going to be installed
 libopenni2-0 : Depends: libudev1 (>= 183) but it is not installable
 libpulse0 : Depends: libsystemd0 but it is not installable
 libqt5gui5 : Depends: libudev1 (>= 183) but it is not installable
 libudev-dev : Depends: libudev1 (= 249.11-0ubuntu3) but it is not installable
 libusb-1.0-0 : Depends: libudev1 (>= 183) but it is not installable
 mpi-default-bin : Depends: openmpi-bin
 ros-humble-ament-cmake : Depends: cmake
 ros-humble-ament-cmake-core : Depends: cmake
 ros-humble-foonathan-memory-vendor : Depends: cmake
 shim-signed : Depends: grub-efi-amd64-signed but it is not going to be installed or
                        grub-efi-arm64-signed but it is not installable
               Depends: grub2-common (>= 2.04-1ubuntu24)
 util-linux : PreDepends: libsystemd0 but it is not installable
              PreDepends: libudev1 (>= 183) but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Originally posted by jgoppert on ROS Answers with karma: 41 on 2022-06-23

Post score: 4


Original comments

Comment by Morris on 2022-06-24:
I'm getting the same error on a brand new Jammy install.

Comment by prawat on 2022-06-26:
I have the same issues with a newly installed jammy

Comment by prawat on 2022-07-01:
After dist-upgrade

$ sudo apt-cache policy libudev1 libudev1: Installed: 249.11-0ubuntu3.3 Candidate: 249.11-0ubuntu3.3 Version table: *** 249.11-0ubuntu3.3 500 500 http://us.archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages 100 /var/lib/dpkg/status 249.11-0ubuntu3 500 500 http://us.archive.ubuntu.com/ubuntu jammy/main amd64 Packages

Comment by prawat on 2022-07-03:
install ros-humble-desktop now works without problems.

Comment by omers on 2022-07-05:
@prawat Can you please elaborate? I am still experiencing this problem

Comment by randychen233 on 2023-01-02:
Hi, I did exactly what's written in the procedures above, and it seems like no error popped up. However, ROS is not actually installed...when the above commands are executed, ROS is simply not there and when I run roscore, an error popped up

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

This is being tracked in ros2/ros2#1287.

As this is a known issue, I suggest (future) readers to refer to that issue, instead of posting here.


Originally posted by gvdhoorn with karma: 86574 on 2022-06-27

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$
0
$\begingroup$

Rosanswers logo

Hi I had this same issue for ROS Humble Ubuntu 22.04. I did some digging and managed to get a solution, that worked for me. See below:

My dependencies

$ sudo apt install ros-humble-desktop       
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

    The following information may help to resolve the situation:
The following packages have unmet dependencies.
apt : Depends: libapt-pkg6.0 (>= 2.4.5) but it is not going to be installed
           Depends: libsystemd0 but it is not installable
     bsdutils : PreDepends: libsystemd0 but it is not installable
     dconf-gsettings-backend : Depends: dconf-service (< 0.40.0-3.1~)
                               Depends: dconf-service (>= 0.40.0-3)
     init : PreDepends: systemd-sysv
     libcolord2 : Depends: libudev1 (>= 196) but it is not installable
     libdbus-1-3 : Depends: libsystemd0 but it is not installable
                   Recommends: dbus
     libgudev-1.0-0 : Depends: libudev1 (>= 199) but it is not installable
     libhwloc15 : Depends: libudev1 (>= 183) but it is not installable
     libignition-cmake2-dev : Depends: cmake
     libinput10 : Depends: libudev1 (>= 183) but it is not installable
                  Depends: libinput-bin (>= 1.20.0-1ubuntu0.1)
     libopenmpi-dev : Depends: openmpi-bin (>= 3.0.0-1)
                      Recommends: libcoarrays-openmpi-dev but it is not going to be installed
     libopenni2-0 : Depends: libudev1 (>= 183) but it is not installable
     libpulse0 : Depends: libsystemd0 but it is not installable
     libqt5gui5 : Depends: libudev1 (>= 183) but it is not installable
     libudev-dev : Depends: libudev1 (= 249.11-0ubuntu3) but it is not installable
     libusb-1.0-0 : Depends: libudev1 (>= 183) but it is not installable
     mpi-default-bin : Depends: openmpi-bin
     ros-humble-ament-cmake : Depends: cmake
     ros-humble-ament-cmake-core : Depends: cmake
    ros-humble-foonathan-memory-vendor : Depends: cmake
    shim-signed : Depends: grub-efi-amd64-signed but it is not going to be installed or
                            grub-efi-arm64-signed but it is not installable
                   Depends: grub2-common (>= 2.04-1ubuntu24)
     util-linux : PreDepends: libsystemd0 but it is not installable
                  PreDepends: libudev1 (>= 183) but it is not installable
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Reinstalled dependencies by sending stdout to file:

$ sudo apt install ros-humble-desktop &> ROS-install-ERR.txt

I tried reinstalling MY dependencies and missing programs that were listed in ROS-install-ERR.txt

$ sudo apt install --reinstall libapt-pkg6.0 libsystemd0 dconf-service systemd-sysv libudev1 dbus libinput-bin libcoarrays-openmpi-dev grub-efi-amd64-signed grub2-common
$ sudo apt-get install cmake

Reason for Error Some dependencies are not installed, and the previously installed versions of the dependencies are not correct, some require downgrade, and some require upgrade.

Solution Install aptitude:

$ sudo apt-get install aptitude

1.

$ sudo aptitude install ros-humble-desktop

You should see a list of dependencies and a proposed action:

The following packages have unmet dependencies:

 ros-humble-desktop : Depends: ros-humble-action-tutorials-cpp but it is not installable
      <Dependencies listed>

The following actions will resolve these dependencies:

     Keep the following packages at their current version:

         ros-humble-desktop [Not Installed]           

2. The first prompt reminds us that there are a lot of things that are not installed let us choose No:

Type: N     

3. The second prompt may ask us to upgrade or downgrade something, this is what we need.

Type: Y

4.

It will then ask you to install ROS files:

Type: Y

5. After that ROS should install automatically.

If however, it presents the following message "-O APT:::GET::Fix-Missing=true" you must execute:

$ sudo apt-get --fix-missing

Repeat Steps 1-5 until you no longer receive this error message.

Hope this helps! Credit where credit is due: User: arahp https://answers.ros.org/question/315820/melodic-fresh-install-unmet-dependencies/


Originally posted by LeonidasEng with karma: 11 on 2022-06-26

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by kolodm on 2022-07-07:
That works for me. Thanks

Comment by RoboFoundry on 2023-01-18:
This helped tremendously!! I was stuck in dependency errors below and this approach resolved it. Thank you so much for sharing this, this is a life saver!!!

while trying to install:

sudo apt install ros-humble-gazebo-ros

I got following errors.

The following packages have unmet dependencies: libignition-msgs5 : Depends: libprotobuf17 but it is not installable Depends: libtinyxml2-6a (>= 5.0.0) but it is not installable E: Unable to correct problems, you have held broken packages.

When I tried to install using aptitude like this, first solution aptitude presented was to keep current version which didnot help so I chose 'n' then it suggested to install a series of packages, when I chose Y, it resolved the issues.

sudo aptitude install ros-humble-gazebo-ros

Comment by JB_nan on 2023-04-18:
helped me a lot,thanks

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.