0
$\begingroup$

Rosanswers logo

Environment: Ubuntu 18.04 ROS DISTRO: melodic LiDAR: VLP-32C

I am trying to convert .pcap obtained from VLP-32c to .pcd file. But I found that there is a ghost effect for each moving vehicle (but not for all). I also tried to visualize the .pcap file using rviz. But the ghost effect still exists. Here are some examples: https://drive.google.com/drive/folders/14SN-BM3HQesi2S4tH7vHYY-aUwK97DeG

The method that I used to read point cloud from VLP-32c was: roslaunch velodyne_pointcloud VLP-32C_points.launch pcap:="path/to/pcap" The method used to convert pcap to pcd was: rosrun pcl_ros pointcloud_to_pcd input:=/velodyne_points _prefix:=/path/to/pcd

I am wondering how to fix this issue.


Originally posted by Skywalker on ROS Answers with karma: 3 on 2022-06-21

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I think what you are seeing is multiple device 360-degree scans being put into the same pointcloud. Maybe you have not set some parameter the velodyne driver needs (e.g. to tell the driver the correct model, or to tell it the hardware's RPM value), or it is a bug in the velodyne_driver code related to reading from a file (instead of a network socket.)

http://wiki.ros.org/velodyne_driver


Originally posted by Mike Scheutzow with karma: 4903 on 2022-06-23

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Skywalker on 2022-06-23:
Thank you for the answers. Yes, I figured that I didn't config the "cut_angle" to 3.14 since I was using 0-180 degrees of view. I found the answer here: https://github.com/ros-drivers/velodyne/issues/248 Hope this can help others with the same issue.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.