0
$\begingroup$

Rosanswers logo

Hello everyone!

I'am trying to install ROS melodic on ubuntu 18.04 by the following installation guide Installation guide

But have a problem on the step #1.4 when I type the command:

sudo apt install ros-melodic-desktop-full

I am getting an error message (sorry, can't upload files yet)

kozinovsky@kozinovsky-GT70:~/Desktop$ sudo apt install ros-melodic-desktop
[sudo] password for kozinovsky:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ros-melodic-desktop

The similar problem I saw on the forum is this: Similar problem

Based on suggestions of this question, here is my output for cat /etc/apt/sources.list.d/ros-latest.list

kozinovsky@kozinovsky-GT70:~/Desktop$ cat /etc/apt/sources.list.d/ros-latest.list
deb http://packages.ros.org/ros/ubuntu bionic main

Also here is the output for uname --all:

kozinovsky@kozinovsky-GT70:~/Desktop$ uname --all
Linux kozinovsky-GT70 5.4.0-42-generic #46~18.04.1-Ubuntu SMP Fri Jul 10 07:09:27 UTC 2020 i686 i686 i686 GNU/Linux

So, the problem itself looks like, there is no package ros-melodic-desktop-full available on the server, but I don't understand why, melodic is currently supported.

Another idea I have is, because I have x32 version of ubuntu (x686, like I can see in the output of uname --all)
And on this page melodic installation
I see in "Select Your Platform" for Ubuntu Bionic "amd64 armhf arm64"
Is this a problem?
Before reinstalling the OS I decided to ask here, what can be the issue.

Thanks everyone in advance!


Originally posted by kozinovsky on ROS Answers with karma: 5 on 2022-02-22

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Can't install Melodic on Ubuntu 18.04 [..] I have x32 version of ubuntu [..] Is this a problem?

Yes, that's the cause of the error you mention.

There are no x86 (32 bit) packages of ROS Melodic on Ubuntu Bionic (ie: 18.04).

See also REP 3: Target Platforms: Architectures.

As you already found, there are only amd64 (64 bit) packages available.

You'd have to install an amd64 version of Bionic to be able to install Melodic using apt.


Originally posted by gvdhoorn with karma: 86574 on 2022-02-22

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by KennyDeDavion on 2022-09-13:
hello, and how to change so that there is no need to reinstall the image?

Comment by kozinovsky on 2022-09-14:
Hi! Unfortunately, you can't change it, you need to redo the imaging with the right image (amd64 in this case)

Comment by KennyDeDavion on 2022-09-16:
thank you, so if I have raspbian and ros melodic on my rpi3, is it not possible to compile with catkin without problems?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.