0
$\begingroup$

Rosanswers logo

Description

After updating to ubuntu 20.04, I tried to create a new config file using moveit setup assistant. However, position_controllers/JointTrajectoryController was identified in the ROS Control pane selector, but position_controllers/JointPositionController was missing.

My environment

ROS Distro: [noetic]

OS Version: Ubuntu 20.04

Steps to reproduce :

https://ros-planning.github.io/moveit_tutorials/doc/setup_assistant/setup_assistant_tutorial.html

I followed the link above to proceed with the movement setup assistant tutorial.

Expected behaviour :

Select Position_controllers/Joint Position Controller from the ROS Control pane selector.

Actual behaviour :

Position_controllers/JointPositionController does not exist in the option.

image description


Originally posted by sm3304ove on ROS Answers with karma: 11 on 2022-01-22

Post score: 0


Original comments

Comment by gvdhoorn on 2022-01-24:
Cross-posted to ros-planning/moveit#3033 and ros-planning/moveit_tutorials#698.

Please do not cross-post like this.

$\endgroup$

2 Answers 2

1
$\begingroup$

Rosanswers logo

However, position_controllers/JointTrajectoryController was identified in the ROS Control pane selector, but position_controllers/JointPositionController was missing.

I believe this is expected, as MoveIt cannot directly use a plain JointPositionController.

It needs a JointTrajectoryController. That's why you only see those in the dropdown.


Originally posted by gvdhoorn with karma: 86574 on 2022-01-23

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by sm3304ove on 2022-01-24:
So should I choose JointTrajectoryController? I used to be able to select Position_controllers/JointPositionController in ubuntu 18.04, why is it gone in the noetic version?

$\endgroup$
0
$\begingroup$

Rosanswers logo

This may happen if the position controller package is not installed for some reason.

Try:

sudo apt-get install ros-noetic-position-controllers

Originally posted by osilva with karma: 1650 on 2022-01-23

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by sm3304ove on 2022-01-24:
I tried the method you suggested, but it says the latest version is already installed.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.